Watched status not in sync with Trakt

I have a 1st gen and a 3rd gen Apple TV. Both with tvOS 17 beta. Then I use the official Trackt app on my iOS/iPadOS devices. I have the latest Infuse Pro (for life), in both Apple TV, mobile devices and my Mac, but I rarely use it outside the Apple TVs. iCloud syncing is enabled in all.

The issue is the following:

  • Randomly, after watching an episode or a movie, the video gets marked in Infuse as watched but that doesn’t reflect on the Trakt app. I think it happens more often if I press the button “Next episode” at the end of the video, but I am not sure.
  • it may happen that a video marked as watched in Infuse, gets unmarked, but with the progression bar full. I think it happens more often switching Apple TV.
  • In some cases I’ve got the watched status reset even after few days, like yesterday. Still the bar was full.

Marking as watched any video with the apposite button seems to always work (and that’s what I use to mark them as watched in case removing the duplicate from the Trakt app).

I am not using Plex or any other 3rd application syncing with Trakt. I seems to have been improved a bit after the recent fix (for jellyfin?). I am surprised I didn’t see any recent post with the same issue. Any idea?

I don’t have a solution for you but I’ve had the same problem for a long time. I have 2 ATV 4K (1st gen) with Infuse Pro Lifetime, with iCloud sync active and login to TRAKT on both. My files are on a NAS (SMB Shares) and no Plex or any other app is involved .

I experience the same watch status reverting to “unwatched” with the progression bar full on some video files. Even some movies and TV shows (random movies/episodes affected) that I’ve watched many months ago get this treatment.

I don’t know what is causing this.

One potential cause is related to Trakt’s database issue from a few months back. This caused some existing sessions in Infuse to become invalid, so it may appear as though you are logged into Trakt in Infuse, but the session info was lost on the Trakt site - which results in no data syncing to/from Infuse.

To ensure this is not an issue here, I would recommend logging of of Trakt on all devices and then signing in again.

Hi @james thanks for the reply. I have logged out an back in in all Infuse, Watch and Trakt apps I have (iPad and Mac included). I’ll let you know if it happens again.

PS: Is it possible to have the “next episode” greyed out when touching the Siri Remote, enabling it only after swiping up? The inverse of how it is now. I keep pressing it by mistake when I want to go back 10 seconds at the end of an episode.

This has been going on for a long time. certainly the last three years. You may have watched a movie and afterwards it is marked as watched. The next day it is changed to ongoing with a few seconds left.

Well, it happened again. I watched an episode, pushed “Next Episode”, the new one started. I checked with iOS Trakt app (as I always do now) and it wasn’t marked as watched. It has been only one day so I didn’t get the issue of a watched show getting unmarked with few seconds left to the end.

I have tried now deleting both Infuse apps from the 2 ATVs, also deleting the Infuse data from iCloud. And reinstalled it again (the installation from one ATV propagated to the 2nd ATV - Probably because I sync the ATVs home screens). I obviously had to log in again in both ATVs. I’ll report if the issue happens again.

I must say I didn’t use Infuse since before the Trakt DB debacle, and yeah, I never had this kind of issue before it. I just hope I won’t have to start from scratch, removing all Infuse apps, also deleting the iCloud data, to fix it. Also because manually marking it as watched always works. And the Trakt/Watcht apps never misbehave.

PS: Also, sometime, I get the Trakt app showing the progress on my iPhone locked screen. I don’t know if it is related, but I’d love to disable it in any case, it’s also useless.

It happened again for me as well. Yesterday, following James’s advice, I signed out of Trakt on both ATV, restarted the ATVs and signed back in to Trakt. I then watched 2 episodes of a series, which were marked as “watched” when done.

Today I went to watch the next episode and noticed that one of yesterday’s watched episode was now marked as partially watched, with the full progress bar. Resume time stamp was 42:51, which is the lenght of the file.

What do you mean by partially watched? If you don’t “complete“ an episode in infuse, then it probably won’t push that to trakt, even if you go to the next episode.

By partially watched, I simply mean that even though it was marked as watched yesterday ( I did complete the episode to the end), it has lost its watched status today and now displays a progression bar showing that it is not fully watched, with a resume time that correspond to the end of file.

Are these by any chance also showing in the up next list on the home page with a full orange bar at the bottom?

NC_Bullseye: I wasn’t displaying that list but I turned it ON to see and, wow! There are a lot of previously watched episodes of many TV Shows that are there, all displaying a “full lenght” progress bar. So I guess the answer to your question is YES.

When I am done watching an episode or a movie, I always swipe right on the ATV Remote to bring the progress bar of the file to the end, thus making sure the file reaches its “End Of File”. This always marked the file as watched.


Thanks for checking, I’ve got a bit of digging to do but this may also point to another problem. Thanks again.

After downloading and installing Trakt, if you log in again, you still cannot synchronize member information. Still prompt to purchase a member!

After watching some episodes completely, the next day there is some episode that it is marked as not watched with the orange bar almost till the end, instead of being positioned on the corresponding episode to watch.

Are you using Trakt?

Yes, I am

I moved your post to a currently running thread discussing this issue. You may want to post what device and OS version your using and what version number of Infuse you’re currently running.

(Sorry about the double hop to get here. Got the wrong trakt thread the first move.)

My device is an Apple TV 4K, last model wi-fi + ethernet firmware tvOS 16.6 (20M73).
Infuse pro 7.5.9 (4501).
But this is not new. It happened with other versions of firmware and infuse

1 Like

So, in the last 5 days the issue seems to have finally disappeared. No more unmarked watched videos, nor watched videos that appear as unwatched only in infuse but with a second to finish.

What I did is the following. It is actually two phases but the first one didn’t seem to work with the unmarked in Trakt issue:

  • I logged off and then immediately on in all my Infuse and Trakt apps.
  • Later I deleted the Infuse’s iCloud data just in case.

This probably fixed the fully watched but marked as unwatched in Infuse issue (as shown in @drakomad picture), but still was out of sync in Infuse.

So I proceed in this way:

  • I deleted from each ATV Infuse app with ALL its data, without installing it immediately after
  • I deleted the Infuse’s iCloud data from iPhone
  • I installed Infuse in one ATV, the home sync installed it automatically in the second

And this seems to have worked. I have got another (different) hiccup, but that happened because I closed the Infuse app in one ATV after pausing it, and kept watching from the other ATV. The watched time wasn’t in sync either, so I has to skip to the point where I was. And after finishing the episode it didn’t mark it as watched in Trakt, and it was still not fully watched in the first ATV.

I believe this is a totally different issue. Just don’t close the app in the middle of a stream…

So, yeah. If anyone wants to give it a try. I believe just the second phase should be enough.

PS: THIS SEEMS TO FIX ONLY THE TRAKT MARKING. It doesn’t fix the issue when we have a fully watched bar but the status is unwatched.

And now I have got the issue with the fully watched episode again showing as unwatched. But that seems to happen when I switch from one ATV to the other.

Me thinks this is a bug that has little to do with Trakt.