Jellyfin (Ubuntu VM) & Infuse (Apple TV) - Indexing Failed


I used to have Jellyfin 10.8.11 on a Windows 10 virtual machine (VMware) and it worked really well with Infuse on Apple TV, no problems. I decided to make some changes, and installed Jellyfin 10.8.13 on an Ubuntu 22.04 virtual machine instead. I also moved all of the media files into an NFS share.

From the web browser (Firefox) it worked fine, very fast and responsive. But on my Apple TV I started getting exactly this issue: Indexing error with Jellyfin 10.8.8 - #15 by Tanc where it keeps saying “Indexing Failedf for Jellyfin”

I was even getting incorrect username / password, when I tried logging in with a new user as someone else experienced in that thread. BTW, the username / pw combo works fine in the browser.

I tried all the usual things, clearing the cache, disabling Infuse Sync plugin (and re-enabling) and even tried uninstalling Infuse Pro and re-installing.

I wonder if it’s because I used the same hostname / IP / username as the old Windows Jellyfin server that it had some stale data from the old instance? I tried changing the hostname of the Jellyfin server, but that made no difference.

This is obviously related to the linked issue, and it’s rearing its ugly head for me.

I’m on the latest version of Infuse Pro. Any ideas? My family are going to leave me out in the cold this Christmas if I can’t get their favorite movies playing :slight_smile:

Update: I just installed Jellyfin 10.8.13 on a new Windows VM using the same NFS share, and the same error occurs. Interestingly, on either Jellyfin instance, Infuse plays find when I click a movie under ‘continue watching’, it only errors when I click Jellyfin and then the library name (E.g. Movies).

I’ll see how I can downgrade to a previous Jellyfin version later and try that, but it seems Infuse needs to be updated to work with 10.8.13.

Okay, so after downgrading to 10.8.11 it now completes the scan / indexing fine. But now when I go to Jellyfin > Movies (or any library) I get: An error occured. Unexpected server response. Please try again.

But I can play media through recent, watching, and the other locations.

This is the same problem I’m now left with: Jellyfin "Unexpected server response."

FINAL UPDATE FOR TODAY: Alright, this is weird but it seems Infuse Pro is caching something on my Apple TV, that even an uninstall / reinstall doesn’t resolve. I just installed the free version of Infuse and everything works! But the Pro version does not.

No replies? I’ve waited for 5 days to get this working. I’ve tested it on 4 different Apple TV devices, and two Jellyfin servers. Nobody else having an issue with the latest version of Jellyfin 10.8.13 and Infuse Pro?

What version number of Infuse are you using?

What ATV model and OS number?

Did you delete the app or offload it?

So I have this issue across each of my Apple TV devices. I deleted the app (not offload) on two of them. Since downgrading to Jellyfin 10.8.11 I no longer get the Indexing Failed error. I can play any media unless I click on the Jellyfin tile to see all the categories / libaries. When I click on ‘Movies’ for example, I get “Unexpected server response. Please try again.”

I’ve since upgraded Jellyfin again to 10.8.13, and the same thing is happening. Funnily enough the Indexing Failed isn’t happening now.

I have a combination of Apple TV 4k and HD all on tvOS 17.1.

Edit: Oh, and it’s worth mentioning that on the free version of Infuse, while it looks different, I get no errors. It just prompts me to buy a subscription when I try and play something.

Probably not related but you may want to update to 17.2

Are you using the latest version of Infuse 7 (currently 7.6.4) or an older version? You can view the version number by scrolling to the bottom of Infuse > Settings.

Also, if you see this issue again, please send in a report form your device and post the 5 digit code it gives you here. This will help us get a better idea of what is going on under-the-hood.

Ok this is the problem. Infuse Pro shows as 6.7, but how do I update it? The free version which I installed to test, indeed says 7.6.4. Do I have to purchase version 7?

OK I am an idiot. I must still have had a Testflight version I installed back in 2020. It’s been working all this time with no issues, until now. I always thought there were two versions, the grey icon was Infuse Pro and the white icon was Infuse 7 (free). I’ve just subscribed to Pro and realized it’s not longer a separate app.

I was always expecting the App Store just to update it! Anyway, it’s now working. Thanks!!

1 Like

Glad to hear you are back up and running! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.