Indexing failed using Plex Media Server

Hi,

I’ve been using Infuse 6 pro as a happy customer for almost a year. Just recently I started experiencing problems where certain new files added to my Plex library don’t show up in Infuse and when manually scanning libraries, I get an error message saying Indexing failed for Plex Media Server. I’m guessing this is the issue. I have quite a huge library. Are there any limitations or is this a bug?

Any fix or update in the pipeline?

Thanks

OK, so I now tried to delete and re-install the app, and the same issue is there except now all my media is gone from Infuse, since “indexing failed” and it cannot fetch anything. I’m sure I’m not the only one with this issue. Can you please have a look into this. Thanks.

Welcome to the forum!

Sorry you’re having problems but a bit more detail would really help.

What version number of Infuse and tvOS?

Can you connect to the same server via a non Plex connection like SMB?

Is the ATV connected via WiFi or Ethernet?

Thanks!
I’m using the latest version 6.5.4 of Infuse and tvOS 14.2.
I can connect to the same share via SMB. My ATV is connected via Ethernet.

Any help is appreciated! I can always use the Plex app, but the exclusion of DTS-HD and TrueHD decoding is what got me into Infuse, so would love to get this fixed.

Could you make sure you’re following the instructions in the Users Guide for adding a Plex share?

It sounds like something in your original Plex settings may have changed either due to a Plex update or possibly a change in Infuse.

Are you able to log into your Plex server using the above steps in the Users Guide?

Either way, it sounds like Infuse is working, it just needs to be dialed back in for Plex.

Hi,

Thanks, but I just tried this, and I think it has to do with the size of my main movie library. When adding favourites, I am able to add my “music”, “kids” and “tv shows” library which are all way smaller than my “movies” library. When trying to add my “movies” library it just states “an error occurred. the operation could not be completed”.

Sorry to sound like such a newb but I don’t run Plex.

Doesn’t Plex set access for each library? It sounds like Plex isn’t authorizing your ATV to read that library.

I’ve heard of people with libraries in the 10s of thousands videos and not having any problems.

Edit to add, was reading here and it looks like a place to maybe check.

Thanks, but I have no problem with ATV reading the library. Everything works fine with Plex’s own app, it’s Infuse that all of a sudden stopped reading and indexing the Plex server. All worked well until a while ago, so either its an update in Infuse or in Plex, or then its the size of the library. I have around 2000 movies all full rips of my blu-ray and 4K discs, so that’s quite a bit of storage space, roughly 55 terabytes in all. I’d happy using the Plex app, but Infuse offers a better experience, most notably for me, being able to decode DTS-HD and TrueHD audio, which the Plex app doesn’t do. This is why I started using Infuse in the first place.

Any other thoughts on this? Am I really the only one with this problem?

Did you ever find a fix for this? Having the exact same problem.

I gave up on Plex and moved to Emby. Works like a charm.

Found the issue, it has to do with TLS. If secure connections are ‘required’ on Plex server, Infuse is unable to connect and shows the error. The moment I change TLS from ‘required’ to ‘preferred’ it starts to work.

Can we please see why infuse is unable to work with TLS/SSL on Plex server?

@NC_Bullseye Can we please understand why we haven’t seen a response to question from the team in over 2 weeks now?

I have broken the info down to a reproducible error that anyone can create, and still haven’t heard back at all.

What else do I need to do to make sure that I hear back?

Infuse is able to work over TLS from Plex. However, there are a variety of reasons why a secure connect cannot be made. Switching to Preferred will allow Infuse to use a secure connection when available, but fallback to standard http when it’s not possible.

Correct, and I would rather not use http clear text for an application which requires auth tokens to be passed in the web calls. Hence the reason for me requesting https required rather than preferred.

Could you please see why https required is failing?

It usually comes down to PMS and/or network settings. Infuse obtains the http(s) access URLs direct from Plex. If the https version is valid, Infuse will use it. If there’s some sort of certificate error or other issue which prevents the https URL from being available, then Infuse won’t be able to use it.

IIRC, we’ve seen a few cases of mismatched or expired SSL carts which were preventing secure connections from working, but I’m not sure how common this is.

iOS also has some security features which Infuse utilizes to verify secure connections. It’s possible for apps to opt out of these and silently connect over regular http, but Infuse does not do this.

That makes sense James, as I am using a self signed cert and CA for it is not imported into the iOS devices.

I will get it signed by a public CA and give it another shot.

I will keep you in the loop how it goes.