Issue indexing from Jellyfin, but only for specific Library

I submitted a support request but I can’t seem to see it via the Zendesk link so made a topic here (my diagnostics are TB2JH) so decided to also make a topic here in case anyone has had the same issues as me.

This behaviour happens on both tvOS and ipadOS.

Using latest stable jellyfin, and infusesync plugin.

I recently had to rebuild my JF install due to a hardware issue, and while I’m mostly back up and running (Everything looks fine on the Jellyfin end and all my media plays fine there), when I add my JF share in Infuse, I get an “Indexing failed” error after “Fetching content” runs for a few seconds.

This only happens for one specific folder, my Anime folder, which uses Shoko Anime as a metadata provider within JF. If I uncheck that Library and Scan for Changes everything not in that Library fetches just fine. Unfortunately, there’s no useful error output that I can pin this down any further as to what is actually going wrong so hopefully can get some insight into it here.

Also noticing this in swiftfin so I suspect it’s a problem with the library but I currently have no way to view logs for either so hoping I can find out the actual error with my library

Just as additional info if anyone else runs into this - I managed to get it to index by restarting my server and hitting scan for changes in infuse just as the jellyfin server comes back up (behaviour which I can replicate with backups etc) so I’ve got a working Infuse now across both beta and non beta versions but this issue still reoccurs if I have ever to “freshly” index my jellyfin server again (say on a new device with no iCloud sync).

Having the same issue from time to time (both tvOS and iOS). Only solution is to “Clear All Metadata” and wait for the refresh of the library.

Just ran into this again with no changes to my library except the addition of some new files to my jellyfin server, pretty frustrating as “indexing failed” isn’t very descriptive.

I’m fully on non beta versions (latest stable jellyfin and latest version of infuse) now as well with the same issue happening if @NC_Bullseye could possibly move this thread out of beta forum purgatory?

Submitted more diagnostics at ZJK0A - also tagging @james (sorry for the notification but this is a pretty frustrating one to run into sitting down on a Friday after work to relax with a show and having the bug retrigger)

Swiftfin is working totally fine throughout this time as well so looks to be on the infuse end only from what I can see.

Done :+1:

1 Like

Looks like this time my “fix” with restarting the server isn’t doing anything unfortunately.

Spent some more time resting with a totally fresh jellyfin install run on a vm with a restored backup and discovered the following:

Native jellyfin clients on various works fine, swiftfin works fine and so does the web interface.

I can play content through infuse browsing to the jellyfin share even as indexing fails (and seeing all the correct files etc)

I’m fairly confident the server itself is fine and something is going wrong with the indexing process on the infuse side. Any insights into a solution would be very welcome before I start setting up wireshark to see if I can pick out any further info.

More digging - it’s only certain shows in the library - if I navigate to them directly I get “unexpected server response” in infuse but fine everywhere else. Can’t see any difference in the files there vs any of the other shows though, they’re all just mkvs with standard file names and nothing weird going on.

Managed to fix my setup once more - for every show I observed an “unexpected server error” for when I tried to browse to the folder directly or do a speed test against from the Shares menu I moved them all out of my Library, rescanned and force recreated the jellyfin docker container which allowed infuse to finally index successfully.

Then I added those shows back in and rescanned, force recreated etc (regular restart wasn’t enough) which also allowed them to sync. Still no idea what caused infuse to dislike the shows but at least we’re back in business for now.

Hopefully this will help some other folks fix similar issues until we can find a permanent resolution.

Still experiencing this on and off, I have a workaround as mentioned above but even improvements to error reporting on the indexing (skipping a show/folder if it has problems and giving me a list of problem shows/folders while indexing the rest of the shows) would save a huge amount of time even if there’s no easy underlying fix to be done.

I’m guessing jellyfin support is a niche case and smaller amount of users vs plex or similar so I do understand it’s not a super high priority but it is still fairly frustrating to deal with. Even just some better error logging so I can solve the problem on the jellyfin side if possible would be appreciated as right now I’m still working with a black box on the infuse side.

Just wanted to flag that I’m still experiencing this on and off and only moving files in and out of my jellyfin library with an infuse index and server restart in between seems to do anything.

Back once again experiencing this issue - it does seem to happen most often when there’s a mismatch between cached metadata in Infuse and updated metadata in Jellyfin (even after clearing the metadata cache in Jellyfin itself).

Still no response on my support tickets or in here so if there’s anything at all I can do to get some insight into what is actually causing this problem I’d really appreciate it. (@james sorry for the ping again but I’m mostly out of avenues for help at this point). I’ve even tried adding additional logging to the infusesync plugin to see if I can get additional data out of the process to no avail.

Submitted some more diagnostics under 1F27D

I might have missed you saying so, but did you fully delete Infuse’s cache from all devices on which Infuse is installed (and its iCloud backup, if present) in between deleting the Jellyfin shares from (all instances of) Infuse and re-adding them?

Individual Infuse installations are not as syncing as quickly as they used to, as well, due to a known but as yet unresolved issue with background updating.

Not a Jellyfin user, but a could of things to perhaps try or consider.

1 Like

Thanks for the suggestion, it’s a good point.

But yep, unfortunately even with a disabled iCloud backup and clearing caches/metadata/shares on every device I’ve got Infuse on the issue still presents itself intermittently. Even doing the above with a totally fresh jellyfin install can trigger the issue (or at least a related issue, because the error reporting doesn’t give me any more info than “indexing failed”).

1 Like

And it appears you’ve ruled out any sort of networking (wireless or otherwise) issues and share folder permissions issues as well …

I’ve got nothing else. Sorry. Hope you get it sorted. Good luck!

1 Like

Yep indeed, I appreciate the second set of eyes!

All the usual stuff is fine, I can have a totally unchanged library setup except a single metadata update in Jellyfin (e.g renaming an episode, or adding a new episode of a show) and then that’s what’ll trigger everything to break. There’s definitely something very weird going on but I am just fairly out of ways to glean any more info since Infuse is a black box from a logging point of view and Jellyfin thinks everything is fine the entire time.

Switching to plex as a backend for now, which is a bummer but at least it works.

Ever tried just using Infuse by itself; or is the thought of updating filenames to match TMDB the dealbreaker?

Unfortunately I have a lot of anime in my media collection that I use a specialised metadata provider for (which uses data from anidb mostly) due to tvdb/tmdb handling those sorts of shows somewhat poorly so plex or jellyfin end up being my main options for using that data for metadata.

Thankfully Infuse + Plex seems very stable for now as a stopgap measure but I would love to swap back to jellyfin eventually as it’s a great backend when it does behave.

1 Like

Did a bit more tinkering again and creating a totally fresh user in jellyfin (but nowhere else) seems to fix this as well (at least for now). Very strange indeed.

Actually made some progress here, it looks like the bug is triggered by a mismatch between what infusesync thinks my user data should be and what it actually is.

Finally have a proper workaround for this - my third party metadata provider plugin has an issue saving to the TypedBaseItems table in jellyfin’s library.db during some actions that persists until a reboot that breaks the query infuse makes against that same table for indexing (and infuse sync as well), so disabling that functionality seems to do the trick for now.

Would still love to know why that query breaks if someone with access to infuse logs from my diagnostics above could share that with me but for now I have a solid workaround at least, that allows me to continue to use jellyfin.

This has been resolved in today’s 7.5.8 update.

Thanks for the report and your patience.