SMB share address issue and 5.6.9


A problem appeared on my Infuse setup on an AppleTV 4K after the update to Infuse 5.6.9. I had a SMB share on a Window 10 Pro 64bit machine in my LAN, set up under the computer name ‘Marshall’. I use iCloud sync to have the setup shared with my iPhone 7 and iPad Pro. Yesterday, the access to this shared drive from my AppleTV 4K stopped working. It was still working on the iPhone and iPad.

After checking my network, I decided to wipe the configuration and restart the setup from scratch, using my iPad. Setup worked nice, access to the computer name ‘Marshall’ was removed , then restored successfully automatically on the iPad Pro, but again, it was failing on the AppleTV.

I checked quite a lot of potential causes, but I finally the solution: I setup the SMB connection using the IP address of the computer instead of it machine name Marshall, and it worked on the Apple TV.

I have a permanent DHCP reservation for the computer so using the IP address is not an issue in my case, but I’m sure you’ll want to investigate the issue. Note that I have another SMB connection to a Synology NAS that hasn’t had any problem, so it might be a Windows related issue.

Thanks. We’re looking into a few other similar reports with Windows 10.

If you have a sec to drop send in a quick report from your device that could be helpful.

Thank you for your quick reply, James. I have sent the log as requested.