macOS SMB network share issue

Running all the latest OS updates to Ventura and ATV. I had read that SMB file sharing was finally fixed in the latest point update and it was working perfectly prior to Ventura.

After applying all the OS updates and setting up a Share in the Infuse ATV app and file sharing in MacOS everything things works perfectly until you Shutdown the Mac. Reboot the Mac and ATV and ATV Infuse APP just comes up with a non specific (ie, no details) ’error’ while trying to connect – as though the Share has timed out.

Delete and setup the Share again and everything is fine until the next shutdown. There were no issues with a share reconnect under Monterey.

I couldn’t find anything on the internet about others having this issue and wondered if it is just something weird with my setup?

1 Like

Perhaps your IP address on the Mac changed? Try giving it a fixed address in your router settings.

1 Like

I read about this “fix” too, and it did nothing for me. At this point Infuse works only on my iMac, because that’s where the files are—no sharing necessary.

I’ve tried forgetting the share and setting up again on my ATV4K and iPad; it doesn’t work. I get the same “error,” no further details.

Thanks for your replies.

Setting up a fixed ip address for my Mac in my router didn’t make any difference.

Did you add the ip address to infuse or the local share name like “John Smith’s Mac”?

Local share name. Infuse found my Mac as a share that it could use and I just authenticated with login name and password – everything thing else was already populated.

I’ve been using the local hostname, entered as iMac.local. For my login name, I use the folder name under Users: e.g. johnsmith, not John Smith.

This worked for years. Not it doesn’t.

I am potentially also running into this issue, although as I am new to Infuse and the SMB share is located on a file server running Debian I can’t be 100% sure this is the same problem.

Does VLC work to access the SMB share from your AppleTV?

I am also having this issue. Everything worked fine until I updated my macos to the latest version. I’ve made sure that I’m running the latest version of infuse on both my mac and atv. I’ve also forgotten and re-added the share. Infuse on the atv does see the share but it will not allow me to login with the previous credentials. I have also unsuccessfully tried to create a new user account for file sharing on the mac that gives me the same error when logging into infuse on atv. Any other ideas?

macOS 13.3.1 released today. Try that? :man_shrugging:t3:

Here are a few things to check.

  1. SMB is enabled on your Mac (Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

If you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again. You can also try one of the tips found here. Ventura SMB Connection Issues

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Change Users & Groups settings on Mac - Apple Support

This update along with turning off/on file sharing and re-adding the shares resolved the issue.

Thanks!

2 Likes

Thanks.

Updated to latest .1 release and followed setup as detailed. I turned off smb ‘Full Disk Acess’ prior to the .1 update and the updated turned it back on by default.

Anyways, no change here. Setting up share from scratch and everything thing works perfectly. As soon as you shutdown the Mac and reboot the share is lost and you can’t connect again unless you go through the same as detailed procedure – turn off file sharing, reboot, turn on file sharing, setup share again, etc…

My separate and totally unrelated to Infuse Synology (not using as a media server) share works fine. Login, logout, shutdown, re-authenticate, all works fine.

I’ve been running Plex server on the Mac as as workaround and of course that works fine streaming to Infuse on the AppleTV.

Could you try using the static IP address in the Infuse share you set up in the router (like 192.168.1.111 etc) instead of the local name?

Setup ‘Other’ share using Mac’s IP address in Infuse. Same result. All works fine until you shutdown the Mac and the share is rejected and can’t be re-authenticated (unless you go through the whole turn off file sharing routine). Checked the Mac’s IP address after reboot and it still matched the Infuse ‘Other’ share IP address.

I’m running an ethernet cable from the router to the AppleTV with a wifi connection from the Mac to the router. I turned off the Mac’s Wifi and replaced it with an ethernet cable to the router. Same result. All works fine until you shutdown the Mac and the Infuse share is rejected.

One other possibility I can think of is to include the MAC address for the Mac in the advanced settings in the share settings in Infuse. Make sure you get the right MAC address for the WiFi or the Ethernet which ever one you want to use.

Tried that and checked the router and Mac to make sure the MAC address was correct. I’ve even swapped the router out for an old Airport Extreme and everything consistently doesn’t work as described.

It still looks like some bug in Ventura’s implementation of SMB as it worked as expected in Monterey.

I’ll just stick with Plex.

Thanks for everyone’s replies.

Couple other thoughts. We’re you sharing internal or external drive? If you have an iPhone/iPad can you connect with that or same issue? Also on iPhone/iPad did you try connecting via the files app?

External drive (DAS).

Same issue using iPad Infuse app. Share shows up and you can play everything. Reboot Mac, Share no longer connects.

Nothing works. None of the above. I created a Plex account and set up my iMac as a Plex server. I had to Fix Match several times (Infuse on its own is much better in that respect) but at least it works again.