macOS Sonoma & Apple TV 4K Setup?

Hey Infuse friends!

I’m a long time Infuse Pro user. Everything had been working (for me) beautifully up until today. Today, I decided to reformat my Mac and install the new OS Sonoma 14.0. I’ve looked over my settings carefully - and I think I’ve reset the File Sharing as I had before, but am now getting an error when I try to connect my Apple TV 4K.

On my Apple TV, I think I used to use my email as the username, and my Mac user system password as the password??? Is that not right? I’m at a loss.

I’m not sure why it’s not connecting. If anyone can help me troubleshoot and get my connection going I’d be very grateful. Thanks!

You have to use your local username/password on the Mac. From what I remember is it won’t work with iCloud credentials. I think I remember some people have to create a separate local user account on their Mac just for file sharing.

Thanks @JarvisMeier I tried my local user name is shawnmeunier with my system password and it still didn’t go. I guess I’ll try making a separate local user account for file sharing, like you suggested. Which is odd, 'cuz I never had to make a separate user account before…

Just made a user called “Infuse” and it still didn’t connect. Any other thoughts?

Here are my Mac’s Sharing settings:
Screenshot 2023-09-27 at 9.13.47 pm

The Folder’s Advanced Settings:
Folder Settings

As well as the User Settings:
User Settings

Here are the Infuse settings on my Apple TV:

These are the Infuse Advanced settings. Should I do anything here? Maybe change the port???

Not sure if any of this is helpful… Thanks again for your advice. :slight_smile:

Make sure a password is set for the infuse user. Try disabling encryption and disabling guest access

You also don’t have the “infuse” user in your windows file sharing.

Edit to add, you may want to step carefully through this users guide and make sure you have all the details covered.

Thanks @NC_Bullseye I updated the Windows Sharing on the Infuse user, still nadda. I also tried making a new user - and made sure my password was different from my Home User - and that didn’t work either. Have also been going over the document trying to see if I missed something. Only thing I can think is that something has either changed with the new Mac OS - or - I’m missing something… I’ll keep trying. I wish Firecore had a tech support number I could call for some help. It’s frustrating because this was working perfectly before. Do you think I need to change the Port in the Advanced Settings or something weird?

I just tried using the Guest Account, by NOT providing a username and password - and I was able to connect and see my Favourite folders.

However, when I tried to open the folder in Infuse, I got the message…

That’s farther than I got with a Username and Password… but still not working. :frowning:

Hey Shawn,
You are not alone in this. I’m having the same issue after updating to Sonoma. Everything working fine last night, today… nothing. Getting the same ‘encountered an error while trying to connect’ message.
I’ve also tried the above suggestions with the same nil result. To me it feels like an Infuse/OS issue, rather than a user issue. Hope Firecore are aware and working on a solution! Sorry I can’t help with a solution.
All the best!

1 Like

Thank God it’s not just me. Appreciate you @GrumbleGnome for chiming in!! I was on with Apple trouble shooting Thursday night - and expect to hear from the Apple engineers in the coming days. I’ve also reached out to Firecore about it again directly to see if they are aware and if an update is indeed on it’s way.

I just posted about this. There’s an ongoing discussion here:

Like you, I’ve read probably everything on the subject, but to no avail.

1 Like

Macs can be a bit quirky when it comes to SMB, and here are some general troubleshooting steps that we have found will resolve issues in 99% of cases.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse
  5. Check to confirm the network address for the Mac (which appears in Infuse) matches what is currently shown on your Mac in System Settings > General > Sharing. In some cases, a Mac may drop off the network and reconnect with a number added to the name. For example, you may see something like: My-Mac-2.local instead of My-Mac.local

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Change Users & Groups settings on Mac - Apple Support

Also, if you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again. You can also try one of the tips found here. Ventura SMB Connection Issues

It’s possible this may also may be related to an Apple bug as there are others reporting the issue here.

There are some suggestions posted in that thread, and they basically entail.

  1. Turning off/on File Sharing
  2. Disabling the Firewall in macOS settings
  3. Disabling all VPNs

If none of that helps, please submit a diagnostic report from your device (and post the code here) and we can look further into what may be going on.

1 Like

Thanks, done all that. Pretty sure this SMB issue has been a problem for a while now. There is a link above to another thread/conversation about all of the people having similar problems with Infuse. Someone in that thread, recommended I make an SFTP server on my Mac and use that to connect to Infuse for now. This method seems to be working. Hopefully Infuse engineers will fix the SMB connectivity issue in the future - either that, or stop promoting that that protocol works on Macs - because it does not.

Not quite

Weirdly, of the three end solutions posted, switching off my VPN did the trick.
Still don’t quite see why it suddenly stopped working as there has never been a VPN issue before, but it’s good to have it working again. Just a bit of a faff having only to have functionality of one or the other. Hopefully a fix will be released!

1 Like

How do I generate a diagnostic report? Does the Infuse Pro app on my Apple TV offer this? Or do they want some kind of diagnostic report from my Mac??? Or both? Please let me know! :slight_smile:

Same link as provided above by @james

I just attempted and it failed, then submitted logs, so the SMB connection fail should be the latest thing in the logs.

Here’s the diagnostic code: GN6PD

It looks like Infuse is timing out when attempting to connect to your SMB device. This often times means the device name has changed, or there is another network related issue which is preventing the device from being reachable.

I just sent you a PM with the device name Infuse is trying to connect to, as I didn’t want to post that publicly for privacy.

Also, it looks like there are some network errors in your logs, and the Apple TV is unable to connect to services which should not have availability issues (EG public NTP servers). This may indicate a wider network related issue which may also have an effect on SMB.