Apple TV 2022 Slow fetching metadata content

Im not really sure who to blame for sudden slowdown (new tvOS 17.1 or Infuse 7.6.2 update) since i didn’t reindex my content in a while.

Apple TV 2022 128 GB is updated to tvOS 17.1 and Infuse is 7.6.2. All worked great few months ago , but today i deleted metadata cache from Apple TV and hit button scan for changes and refresh metadata.

And it takes forever to fetch content data from SSD drives. I have Asus AXE 16000 attached to 4x8TB SSD with 5000+ movies and TV series. Local share is FTP with around 500 Mbit/s . Usually it fetched metadata content really fast, aprox in 30 min , but now is really slow, needs 5 hours more or less.

I check speed,and it shows 520 Mbit/s. So,obiously there is some tvOS Infuse issue, because on Mac with MacOS Sonoma 14.1 is working great as usual , fetching is done in 30 min (900 Mbit/s) but on Apple tv is slow as hell .


Do you by any chance have “Embedded Metadata” turned on?

No, it is turned off

Infuse has a number of steps for metadata fetching, are you seeing one step is slower compared to others?

  • Fetching content (accesses share and TMDB)
  • Fetching artwork (accesses TMDB only)
  • Fetching details (accesses share only)*

*While this is done over the local network only (or directly between a remote server), this involves reading file details which is generally be the slowest part of indexing.

For fun, you may try changing the network connection to see if the speeds change (EG switch from Ethernet to Wi-Fi, or vice-versa).

Restarting devices never hurts either.

1 Like

Hej James

Yes, i tried restarting router and apple tv few times. When i tried to use wired connection it is slower than WiFi but not by much. 550 Mbit/s on WiFi and wired aprox 450-500 Mbit/s

I noticed that Fetching content and details is extremely slow while fetching artwork is fast.

1 Like

I have the same issue on mine. It’s been like that for a while now. Takes ages to update metadata.

I’ve had no changes to hardware or software, other than updates to tvOs, infuse and plex.

As my library is a Cloud Library and has gotten larger and larger - it now takes upwards of 30 mins to fully refresh the library even if all I do is add one movie.

It’s why I wish I could just keep a manual infuse.csv that Infuse uses if it exists so I could update it to tell it “there’s only one movie added” as I’d just add a manual entry when I added a movie.

But 30 mins load time adding a single movie isn’t so bad. But I imagine it might frustrate some users.

You can always use Folder View for an instant connection.

@james is there any possibility of something like an “infuse server” that could run directly on NASes and clients could connect to it? That would solve so many of these sync-related issues if an always-on server handled the library functions centrally. There are two things that make me want to ditch Infuse, as much as I love it, and this is one of them. Kodi/Plex/etc libraries “just work” but Infuse is temperamental to say the least, seemingly because clients struggle to get through the whole sync process cleanly, especially in a situation where the client app is likely to go into background mode and battle with Apple’s black box limitations.

Edit: added as a thread in suggestions

I think this might be an issue with FTP. I just ran into this myself, and I’m specifically testing fetching speed between SMB, WebDAV and FTP from a Synology DS1618+. I’m on an 2022 ATV 4K on tvOS 17.4, connected over 1Gbps Ethernet, Infuse 7.7.3.

Over FTP, “Fetching details” takes extremely long, most of the time it’s more than 10 seconds to advance just one file.

SMB and Webdav don’t seem to have this issue, but I have other issues with both of them. SMB is slow while streaming, close to halving the line speed. It’s not an issue for local streaming (~520 Mbps), but when streaming over a VPN, the ~15Mbps really makes a difference compared to the ~35Mbps Webdav does, basically saturating my ~38Mbps upload speed at home. But, Webdav is considerably slower in “Fetching metadata”, about 3 times more than SMB. I was hoping FTP would not have these issues, but it slows down horribly while “Fetching details”.