All new titles are being listed as a tv show called Stereo

Hi all,

This has been a relatively new issue for me. When I have been dropping tv shows onto my NAS (movie metadata displays correctly), the tv show will load as ‘Stereo.mp4’ (regardless of file type etc)

I have used the recommended naming convention (title_season_epsiode) but to no avail. Even if I then select ‘use embedded metadata’, the thumbnail changes but the file name is forced as ‘stereo.mp4’ which makes life difficult to find a new file, when they are all labelled the same.

Any help appreciated!!

Welcome to the forum!

First you’ll most likely want the Embedded Metadata turned off. Next, are you connected to your NAS via DLNA or another protocol like SMB?

Thanks for that. I’ll look to turn off embedded metadata in settings as suggested. I’m connected to the NAS via DLNA.

As I say, movie files have been fine but for the last few months I’ve encountered this issue with many tv shows. They do seem to be titles that don’t appear when manually searched for but it still forces the name change to Stereo.mp4 too

When using UPnP or DLNA, these servers can actually adjust the filenames before sending them to Infuse. It sounds like this may be the case here and your DLNA server is renaming the files to Stereo.mp4 and that is what Infuse is seeing.

To check this, can you try using the Edit option on one of these files? Doing this will show you the exact filename Infuse is receiving from your DLNA server.

Thanks for your reply. Yes when I go to edit, the file name is stereo.mp4.

It only happens for these tv shows.

Are you able to point me in the direction of where I can research how to avoid DLNA doing so (if that’s what’s happening?).

I’m loving infuse but this issue with tv files makes things so frustrating.

Thanks again

Edit: just to add… at least I think I’m using DLNA. My NAS is hardwired to my network and then I connect to that using infuse, picking it up. To send files, I have the NAS public folder as a shortcut on my iMac and I drag and drop from the file folder on imac, to the nas folder

Hi all, sorry to be confusing… I’ve done some research and confirm that I connect to the NAS via SMB.

Just went on the iMac and checked the ‘connect to server’ details. From there it’s smb://_nas drive

As you say, when I select edit on infuse, it is showing as stereo.mp4 so this might then not be the fault of infuse.

If anyone has any pointers on how I force the film name to be used when transferring, much appreciated.

When I open the folder on the NAS the files are named correctly, however.

I have opened a file that has the issue on the NAS, in VLC to check the metadata. Everything looks normal. The only reference to stereo is the audio channels in the coded detail. Is it possible that infuse is some how grabbing this field instead of the file name?

Many devices will support multiple connection options, and you see which method you’re currently using to connect in Infuse via Infuse > Settings > Shares > Share Name > Edit.

Thanks James. You’ve found the key!

I went into the infuse settings and it was connecting to the NAS via UPnP. I then connected via the available SMB option and it’s suddenly all fallen into place. The main home screen now resembles what I originally expected but never got (splitting by genres and recently added etc). So much different.

And importantly this has fixed the file name issue. They are now all suddenly showing correct.

One question I had, I often use the shortcut folder that I have created, to scroll through the folders. It is currently listed last in the row of ‘Favourites’. Is there any way to move it across so it appears first?

Regardless, want to say a massive thanks for your assistance. It was my lack of understanding when first connecting which was at fault and infuse now suddenly looks like a much bigger and better app!


SMB allows for some other nice things, including use of Infuse’s Library features. This would allow you to browse content via a set of categories and filters - and you can add any of these as Favorites or Lists so they appear on the home screen. More info on this here Managing Favorites & Lists – Firecore

With regard to folder Favorites, these will be sorted alphabetically and unfortunately it’s not currently possible to re-order this row. Sorry. You may try some of the Library options described above, as these can be quite useful.

Although I haven’t done this myself, I remember seeing this workaround mentioned: create the name with a leading space and it will appear at the start of the list.


Thanks so much to all for your valued assistance. Very much appreciated! It’s been bugging me for a while and now you’ve pointed me in the right direction, Infuse is like a whole new beast!

Thanks again :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.