The Simpsons from media server isnt showing as a TV Show

So this is happening on all my devices with Infuse.

The Simpsons is the only show that it’s doing it to. Each episode is showing up as whatever metadata can be fetched for a movie close to the title of that episode.

I have the files in TV Shows/Simpsons/Simpsons.SxxExx.m4v

I had them listed as The Simpsons but saw a post on here saying they fixed this issue by removing the “The” this hasn’t worked for me. All my shows have the correct metadata so its not like thats somehow tripping it up. I’ve deleted the episodes from my server and added them again but its still doing it.

I’ve tried placing them in Season folders. Nothing. Tried basically every naming format I can and thats not fixed it either.

What type of device are you streaming from? Have you tried using the Edit option in Infuse to find a match manually?

It might be interesting to know the filename that is listed on the Edit page, as this is what Infuse uses to find matches at TheTVDb. We’ve seen a few cases where certain servers change this name before sending it to Infuse, which can interfere with matching.

I’m streaming from an ASUS routers USB port which ive got an external hard drive plugged into. The edit option really only shows me other movies with the name of the episode. I can’t seem to search for episode titles.

When I click edit the filenames are showing up as “episode title.mp4” this isn’t what they’re listed as on the hard drive. It seems to be the default way infuse is showing them. Even with “show filenames” turned on the episodes are showing as “title.mp4”

I’ve just resorted to embedded metadata which is slow but at least it seems to work. Whenever I turn embedded off it will search for the metadata as if they’re movies again. It’s currently doing it with a few more shows now.


I’ve figured out the issue. For some reason the TV Shows which have embedded metadata from the iFlicks app are showing up as “FILENAME.MP4” regardless of their name and filetype. I used YATE to scrub all the identifying metadata from the files and now they’re being found by Infuse’s metadata fetching. I’m not sure why this is an issue, maybe its something you guys can look into?

Are you by any chance using a DNLA connection to share the files to Infuse … if so then the problem is the DNLA server changing the filnames that it is sharing.

If the system from which you are sharing has the option to share via SMB then use that instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.