Unable to login to MEGA (Resolved)

Hi, is anyone using MEGA and having difficulty streaming? I had MEGA and all was fine but now I can’t get it load up. I’ve tried removing the share and adding it again but it just buffers with the message ‘confirmation received, logging in…’ but that’s all it does. I’ve tried on the MacBook Pro, the iPhone and I can’t see anywhere to add a MEGA share on the TV. Strange as if I go into the MEGA app, I log straight in so it’s only through Infuse that I have the issue :man_shrugging:t4: Please help :pray:t4: I’m halfway through Game of Thrones… yeah, I know I’m late to the party! :joy:

Have you updated Infuse to today’s 7.5.1 release? It has some improvments for mega.

1 Like

Hi there, no I hadn’t but I just updated and it’s still the same. I would uninstall and reinstall the app but it’s across all devices so I don’t think that would help. I can rule out Wi-Fi I guess as I can still connect to MEGA outside of Infuse. Weird and it’s been like it the last few days :pensive:

Which version of iOS are you using?

I just did a quick test here on an iPhone running iOS 16.4 and Infuse 7.5.1 and the login worked straight away. :man_shrugging:

Can you try restarting your device and/or updating to the latest Apple software (released this morning)?

Hi James, I’ve just updated to the latest iOS and I’d updated Infuse but I’m still getting the same issue. If it’s working for you though it must be something in my set up blocking the connection. Odd but I’ll just keep trying. Thanks for checking.

Just buffers for ages and then the message is Infuse has encountered an error and is unable to login. If I go into Mega, it logs in straight away.

Can you post a code now you are in latest versions?

Hi there. Well interestingly enough, I finally managed to get MEGA to show up as a share BUT the folders are wrong. They’re how they were historically so perhaps they’re showing from what Infuse saved to iCloud previously :man_shrugging:t4: Not sure how it works. It’s very odd. As a test I set up another MEGA account and that one connected. Still a bit slow but connected nonetheless… though to be fair on that occasion, the speed may have been due to bandwidth.

So although MEGA is connected, this is what I’m now getting on the iOS. MacOS has the library as expected though :thinking:

Completely deleted the app on iOS and reinstalled and because I had managed to connect MEGA through MacOS, the library populated eventually. For some reason I could not do it through iOS. Odd but resolved… sort of. Thanks for the offers of help.

This is noted at the top of the instructions for connecting to cloud services:


Infuse supports streaming from many cloud services, including: Dropbox, Google Drive, OneDrive, Box, pCloud, Yandex.Disk, and MEGA.
Streaming is available on iOS, Apple TV, and Mac however connections to cloud services can only be made on iOS and Mac. Once a connection has been made, this will sync to other devices via iCloud.

Thanks. I knew that though. I’m not sure what you’re trying to tell me. Did you think I was trying to add it in TV? I wasn’t. I was only able to connect it through macOS and that took ages and through iOS it wouldn’t connect at all. Connecting through macOS did populate iOS but it was the old directory structure. It took deleting the app again completely for it to spark back into life and populate correctly.

Anyway, I’m sorted now and I had marked the title as resolved. One of those things I guess :man_shrugging:t4:

1 Like

Apparently. My apologies.

Saw that you got it sorted, but the intent behind my posting the references is providing context that might be useful to people who visit the site later, when experiencing similar difficulties.

1 Like

Fair enough :+1:t4:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.