Infuse 6 - QNAP SMB - Can't login anymore

Hi,

After updating to Infuse 6 Pro I’ve unable to access my QNAP.
I can access my Apple TimeCapsule but I can’t add my QNAP anymore, I already deleted the share and tried to connect again.
Nothing.
This is quite frustrating it started with iOS in Infuse 5 and now with Infuse 6 for Apple TV.
I’m gonna start over, deleting app all the cache (it will take sometime again to scan again, time consuming) and reboot.
I didn’t change anything on my QNAP.

:frowning:

Sorry for the trouble.

If you have a chance, can you send in a quick report from your device and open a support ticket so we can look further into this?

After reseting everything and clean al the caches it still doesn’t work.

I just send you the report H2CJ1

Thanks for the help.

This seems the same issue I’ve reported a few months back but now with wired connection.

  • (wired) Qnap → Apple TV - doesn’t work with SMB (at least in my network) with Infuse v6 (it worked fine with v5)
  • (wireless) Qnap → iPhone - it still doesn’t work with SMB neither with v5 or v6

I can open the SMB using my computers via wired or wireless.
I enable webdav and it’s working but I don’t want to use webdav I want to use SMB

:frowning: It’s frustrating the time spend on this (I’m NOT saying the Infuse is bad ok, this kind of issues when they appear are time consuming)
I’ve been a infuse user since v3 (If my memory don’t trick me) for me is the best one out there, easy to use and explain to my wife and kids :smiley:

I just don’t know what to do more.
My cache was about 4GB and now it need to be redone when a fix
It could be something on my end but I didn’t change anything, only the Infuse App from 5 to 6

Please don’t see my post a rant because it not is just frustrating :slight_smile:

Keep up the good work.

Nothing as changed with the new version, I can’t access my QNAP using SMB with my Apple TV 4.

:frowning:

What version of SMB are you running on your QNAP?

Same here, latest Infuse (updated today) and Qnap NAS. v5 worked well, but now Infuse v6 is unable to connect to NAS. I regret putting apps on auto update :frowning:

Is there something I can do to help to solve this asap?

EDIT: ATV 4K latest TvOS wired, iphone and ipad, Qnap with latest version

My solution for now was to enable and use webdav(https) on that user. But if I try to add another location it crash the app. I didn’t yet reported but I will to see if they could fix it.

I fixed it! I forced Qnap to use min. SMB2.1, max. SMB3. Min. was SMB1. I don’t know if Qnap has been all the time offering SMB1, but at least Win10 shouldn’t support that anymore, and still it worked fine with Win10 too.

Could it be that infuse reverted to SMB1 if it was available? Don’t know, but now it works :slight_smile:

I remembering trying that without luck, I’ve tried again the issue persists (with iOS) I need to try later with AppleTV4 :frowning:

The SMB version that seems to solve many problems is the “Legacy” setting. That works with either SMB 1 or 2 on the server side and has a different implementation than the straight SMB 1 or SMB 2 Settings.

SMB 1 was disabled in windows 10 1809. If a higher version of SMB is offered windows 10 will always use that setting.

Any good news on this? I’ve done everything that I could thought but nothing helped. Only using the webdav connection.

Can you try today’s 6.0.3 update? This includes a number of improvements for SMB, which may help.

I’ve tried with iOS and the new version and is still the same I can’t connect directly using SMB. I will try the tvOS later and let you know the results. :frowning:

Thanks

If you have a chance, it might help to remove and re-add the share. This will ensure Infuse has the correct username/password to log in.

It’s what I’m doing, it’s like a fresh installation/setup. Thanks

Do you have jumbo frames enabled on your NAS? Try 1500MTU on your NAS and router if you do.

I have a qnap NAS (451+) and have had zero issues with SMB. I’m just trying to think of why your’s is different.

I’ve tried with all the options 1500 4074 7418 9000.
My default setting was with 4074 (and it worked great with Infuse 5)
I’ve changed now to 1500 and it’s still the same. I’m gonna check the router (but I don’t remind seeing any type of settings for this).
I’ll keep up posted.

Thanks for the tip.

There was definitely a setting on my old Nighthawk R7000 and my current Asus router for Jumbo frames. I believe it was settable to the exact MTU in my nighthawk, and simply a checkbox to enable in my asus.

Also, try your apple tv on wifi if you can, perhaps there’s something weird going on with the switch in your router.