"this Apple TV is not eligible for this version" ?

Apple TV 2 A1378

4.4.4 & 4.2.1


I have many times jailbroken other 4.4.4 using seaonspass on my windows 7 PC.


When i plug in either of the units, and select the corresponding firmware… as soon as i plug in the unit and seasonpass checks for saved firmware signatures i get the error “this Apple TV is not eligible for this version”.


I can not dump the blobs via ifaith either and do not have access to a MAC.


any insight is helpful.




Here is a current discussion on the same issue. 

Yeah that’s not the same thing but thanks I am having that issue with amother brand new 4.4.4

Seasonpass for some reason requires me (on my win PC) to ask twice.  First time it says not eligible and second time it starts to download.  I guess the server letency is too high for the impatient Seasonpass program.


I’ve been doing this a long time… I’ve tried multiple times, changed cables, rebooted, reinstalled seasonpass… basically everything I can think of and there doesn’t seem to be anythinf that will work.

The only thing I haven’t tried is on a mac