Apple TV isn't eligible 4.2.2

I just bought my ATV2 today and, like an idiot, I updated to the newest firmware (4.2.2) without saving SHSH blobs or anything. You’d think I’d learn after screwing up an iPhone jailbreak and an iPad jailbreak recently…

I have the newest iTunes and Seas0nPass but I’m getting the ineligible error within iTunes that others seem to be getting. I tried restoring the ATV via iTunes and beginning from fresh - no dice. I tried PwnageTool and followed this tutorial and I get the same error. I checked out two other posts on the forum about this and they didn’t help. I’m sick of jailbreaking iDevices! I remember the good old days with the ATV and plugging in a flash drive…

Any ideas?

I did a little more scouring and found out about changing the verification servers to point to Apple rather than Cydia. Changed this, nothing different.

you should be able to restore back to an earlier version or use seasonpass if using 4.2.2

i restored an atv2 yesterday then did a jailbreak no probs with the current seasonpass

just checked it and it definitely is 4.2.2

and no i didnt save the blobs 

That’s weird. Why is mine being picky? I just tried again and now it gives me a 1600 error instead.

Attempt number two and it is just sitting there telling me that the Apple TV is preparing for restore…

GRR!! I’ll try a different computer altogether tomorrow. Bed time.

a thought you only have the micro usb cable connected,  no power cable?

 

Looks like it was something with my computer. I tried using Seas0nPass on another computer and it worked like a charm.

Now I’m running into an issue with the Media Player (or whatever the default one by Firecore is called). The installation fails every time. Suggestions?

It isn’t just your computer. I’ve run into the same exact issue. I tried it on a different computer and it worked as well. I’ve sent complete system information to fireCore support to help them determine what’s going on. I imagine we aren’t the only ones who have or will run into this problem.

some problem here

Try adjusting your hosts file as described here.