MKV Subtitle problems

I’ll get something out of the way first - Infuse on tvOS is the exact app I’ve wanted to use for years. Great job.

Now, onto an annoying bug I’ve found - MKV subtitles don’t work. Or more precisely, they work intermittently. The app will recognize the subtitles, but will only ever display one out of every 4-5 lines. This goes on for as long as I’ve tried running a video. SRT files work fine, as does subtitles downloaded from Infuse’s in app subtitle search (a godsend, that) - but I’ve gone through the trouble of mixing in subs to a lot of my MKV files (a necessity for the days when I was forced to use DLNA for my streaming needs), so a fix for this would be great.

My entire collection is muxed this way. Yes, please resolve.

Regards,
Brian

I have the same problem.

So nowadays… is it possible to use .srt subs named the same as the main file?

Yeah, .srt’s work fine. That’s the workaround I’m using until fire core fixes the MKV issue.

Thank you for answering!

What language are your subtitles in?

It may be worth trying to set the encoding type manually (drag down while a video is playing and navigate to the subtitles tab) to see if this helps.

English. Please fix.

Hey James.

Virtually all my subs are Spanish UTF-8, though I’ve had this problem testing out other languages too (English for sure, can’t remember which others I’ve tried).

Also, I Don’t get an option to change the encoding type (or to apply a time offset) when selecting the muxed subtitle track, only for .srt files.