Problem loading subtitles


I just bought your app (Infuse Pro v2.3) and it’s great but I still can’t play any of my movies with the correct subtitles.

I have the movies stored in a WD My Cloud disk and I’m playing them from an IPad Air. The filename for the movie and the SRT file are exactly the same for every movie.

When playing the movie the subtitle is not recognized by the application ( it says Subtitle → None) and I only have the option to download the subtitle from (Spanish). This option is working OK BUT the subtitles available are in Spanish from Spain and I need them in Spanish Latin American. The subtitles from Spain are not an option because the translations are very different.

I’ve tried to open the SRT file and Save it As Unicode - UTF-8 with LF Line Endings but with no results.

Please advise.


Do you know if you are streaming via SMB or UPnP?

Some servers don’t make SRT files available when streaming via UPnP, and the best way to check is to see if the SRT files themselves are visible when browsing the share through the Add Files menu (tap + icon on home screen).


You’re right my shared was UPnP and the SRT files where not visible. I changed the shared to SMB and now i can see the SRT files BUT the problem is that in this way (SMB) is very hard to organize and filter the movies By date, By Folder, Album ,etc as opposed to UPnP.

is there anything else that can be done to keep sharing by UPnP and see the SRT files?



The upcoming version will provide some additional sort options that should hopefully make browsing via SMB a little more flexible, but other than that we’re a bit limited since Infuse will only be able to see the files that are being broadcast by your NAS via UPnP.

One other option (though it may be more trouble than its worth) is to embed the SRT files inside the videos using something like Subler ( Infuse will have no trouble reading subtitles that are embedded within a file.

Hope this helps.