Media player wont play mp4 files

I have hundreds of mp4 movies and when ever I try and play one I get the the error “Playback error - An error occurred loading this content”  The same movie will play if I load it into itunes and use the itunes player on the atv, but I can not get them to play with the firecore media player.  Any suggestions?

mp4 files playing just fine here using Beta 7 and the new Media Player via my NAS setup.


Not sure what is happening.  I guess I can try and re-jailbrake again, and reload beta 7.  Very frustrating, I have had this for about 6 months and it rarely works right.  Has anyone else had this issue and if so, how did they fix it?

Same problem with one of my two atv2 !!!

I did jailbreak and reinstall everything again, but it still doesn’t work…

Best to submit a bug report if you’re still having trouble.


I did that.  No response yet.  However, that was  a few days ago before Beta 7.  Tonight I will re jailbrake, reinstall, and if I still have the same problem, then I will submit a bug report again.



That would be great. Thanks.


James, I re-did everything. still having the same issue.  I did submit a bug report -

#19466 Media player wont play files


Please help me if you can.



Issues here as well as I cannot play any M4V which I could with the previous version. I have submitted a bug report - Request #19476.

No music files can be played through the new music player as well.



alanscoachdriver I have the m4v issue as well. Did you get a resolution?

I too have an issue with mp4 files. They will play, but I cannot fast-forward. If I create the file as an AVI-it works fine. I too will submit a bug report. It worked fine in the first generation,

Well 10 days have passed since I raised my ticket and no feedback yet.

So at present this product is worthless for me. :( 

We’re looking into a few similar issues - so hopefully the fixes will be included in the next update.

I have the same problem more or less. I have some mp4 files that I’ve got from Movieberry and they are played fine in media player, bur when I rip dvd’s with Handbrake the files wont play.

If you haven’t done so already, sending in a bug report will be your best bet.

is there any solution for this Problem? I’ve got the same issue. Can’t play any mp4 file.
I’ve got some iTunes downloads which all can be played over iTunes share but not over the firecore mediaplayer.

I would expect that most movies downloaded is iTunes would not be playable via Media Player as they are likely to be DRM protected, and Media Player cannot play any Movie that is DRM protected.