JB for 5.0 does not work


I have an appleTV 2nd gen, with firmware version 5.0.

I run the new seasonpass without any glitches, than iTunes takes over and both end up stating the process is successfully done, but the light on the front of the atv does not stop blinking. When I connect it to the TV (without disconnecting from power), theres only the iTunes logo. So I assume, it’s still in DFU-Mode? Then I try the tethered boot, which also goes through without any error messages. But when I connect it back to the TV, I have the unbroken, original firmware.

I tried this for several times now with minor changes in the setup, but nothing works. The initial jailbraking just does not seem to “finalise”, although sesasonpass says of no errors.

I successfully jailbroke for 4.3 with exactly the same environment. Any ideas? The only thing I could think of is, that due to the space between TV and Mac I used an USB-Hub to bridge the space. Could that be the reason, should I buy another USB-cable? Would like to know for sure, because it would be quite an expedition for me :slight_smile:

Any ideas would be greatly appreciated!



Same thing for me with firmware 5.0


I don’t think your USB-Hub is a problem, I’ve done this here with a small USB cable (same cable worked fine for several jailbreaks before).


I’ve sent email to support concerning this problem, I’ll let you know if they give me the solution.

Please let me know if you fix it first.




I got the same problem occurring. 
The jail breaking works fine, and completes without any problem, but when i want to confirm that the jailbreak is successful and connect it to the TV, to be sure that the FC logo appear, i fails, and seems like its still in DFU mode. The only thing appearing on the TV is that the ATV wants to be connected to iTunes.


Would be awesome with some help. Either from anyone who had the same problem, but got it solved, or from the developers/support admins. 

One other thing I forgot to mention in my previous post, when you use the boot option watch the “uploading” progress bar. The first few times I tried to boot, I only saw one item appear in the progress bar. All of those boot attempts failed. The last time I tried I saw more then one thing show up, “uploading X” then “uploading Y”. I’m just guessing here but I think what happened is that I wasn’t really in DFU so the boot patches weren’t being applied even though it said they were. I’ve never had trouble entering DFU w/o the power plugged in, but it seems like during the boot step when you have to plug both USB and power in you have wait until the lights start flashing quickly before holding they two keys down.

Try this for booting:

  • Connect USB, then power
  • Wait for the lights to go from a slow flash, to fast flash
  • Hold play/menu
  • Watch the progress bar, more then one item should be uploaded
  • Once you get the complete message, dismiss it then replace USB with HDMI
  • Repeat process until you get the timing right

I had the exact same issue with the iTunes logo showing up after my first jailbreak. This is what I did to fix it;

  • Open iTunes, connect USB to my AppleTV and do a restore to the latest software from Apple
  • Connect my AppleTV to my TV to verify the 5.0 software from Apple was working
  • Disconnect the AppleTV from my TV
  • Open Seasonpass, choose jailbreak
  • Connect only the USB to my Laptop
  • Disconnect the AppleTV
  • In Seasonpass, choose boot option
  • Connect USB, then Power, then hold hold both keys on the remote to enter DFU
  • Replace USB with HDMI

Getting the timing right on the boot step was tricky, it took 2-3 tries. This was my first time doing a tethered boot, but every time a new iOS update comes out I’ve had more luck doing a restore to Apple’s update and then jailbreaking vs. trying to skip straight to new jailbroken software. I don’t know if you are supposed to restore to the unhacked software first but it’s always worked first try when I do it that way.

Ya… got the same problem. It did successfully upload everything, but still it shows only the Itunes/USB Logo when connecting to TV.


ARGHHHH… i just realise that this is a teathered Jailbreak. Ohhhhh… didnt knew it. That explains everything.


Breeza, I have the same problem - did you manage to fix this?


I can’t seem to access ATV2 in Itunes anymore. When I plug it in the TV there is the picture of the Itunes/USB Logo…

For me it worked.


When you get the Itunes/usb cable logo you need to do a tethered boot…with both the power cable AND usb cable present then after the boot is finished just take out the usb cable(the power cable should be present through out the whole procedure).



Help.,… I have done this I am not sure how many times, but still get the itunes icon when I start up the ATV. I have tried both “the old way” and with power like suggested in a previous post. Is there anybody who have a bright idea for me to succeeed?





I am not an expert so I can only explain how I did it:

  1. Do the create IPSW procedure and let iTunes restore it to your ATV.

When this is done and you connect your ATV to the TV, it will show the USB cable/iTunes logo. This means you’ve got to do a tethered boot.

  1. Have the power cord and the usb cable connected to your ATV, no HDMI connected. In seasonpass click the tethered boot button and follow the instructions.

After this has finished your ATV should be jailbroken.

  1. Disconnect the usb and plug in the HDMI cable. Power cable should still be connected, don’t remove it.

Now your ATV should boot up properly, ask for some settings and you should have the firecore (fc) button available.


That’s what I did and it worked for me at least.

I managed to Jailbreak and do the tethered boot. The Fc logo appears above Settings but I can’t see any of the previous options (No media, Browser, etc). What’s wrong?

Run ATvflash from firecore on you pc or mac

After auto reboot you will have these icones


I don’t remember what options I had when I jailbroke mine ATV but you have to install ATV Flash in order to get the media player, browser and the other stuff. That is unless you install the stuff through ssh with apt-get.


Oops, I forgot to… now it’s working!

Have you actually run the FireCore installer to get the maintenance menu added (and via that the other FireOcre components).  It sounds as if you ahve just jailbroken and done nothing else?

Yes, until you disconnect the power…