Desperately need assistance :( (SOLVED)

Hi everybody!

This is my first post, so please forgive me if I posted it in wrong section. First of all, just wanted to thank everybody who works hard on making jail-breaking possible. Even though it does not mean much coming from simple person like myself, I just wanted you to know there are many out there appreciating your hard work.

I have one huge problem and I have no clue how to fix it.

I purchased my Apple TV yesterday and patiently waited for this jailbreak to come out. My ATV came with 4.4.3 and asked me last night to update to 4.4.4 which I did. The thing is,  when I want to jailbreak it with SeasOnPass, I connect it to my Mac with Micro USB cable (no power cable attached), and instructions are saying I should see ATV’s light rapidly flashing. There is no light flashing, just blinked twice when plugged into my iMac, and nothing afterwards. Does anyone know what should I do and how to approach this problem? Oh yes, I just tried restoring it through iTunes and it did it without any problems, but the problem still remains. I still can’t see light flashing rapidly, so I can’t proceed with steps 4-5 and forward.

I hope someone can help me.

Thanks in advance!

Fixed it! I followed these instructions and I trusted them wholeheartedly since I remember I saw led flashing rapidly when I connected my Apple TV to my iMac yesterday, but the only difference from today was the fact that I had power cord plugged in yesterday.

Anyway, these instructions helped me:

Power cord needs to be plugged in just before you proceed with STEP 4. Unplug the power cable, leave the Micro USB plugged in, and after couple of seconds LED will start flashing rapidly. That’s when you press and hold MENU + PLAY/PAUSE button for 7 seconds.

After that, everything went flawlessly, jail-breaking passed with flying colours. I just connected it to my TV and I can see red FC logo in the bottom right corner of the screen.

Does this mean that some Apple TV units, or is it just the version of the firmware 4.4.4 (3330), and the OS build version which in my case is 5.0.1 (9A406a), can not be put into DFU mode without having power cord connected to the device prior to jail-breaking?

I hope this will help someone with the same problem.

Cheers!

but try a new (non cheapo) cable becasue that seems to work much better. It did for me without fumbling with power etc…

 

 

 

This one is not cheap cable. It’s purchased at Apple store and recommended by Apple:

[[wysiwyg_imageupload:142:]]

 

[[wysiwyg_imageupload:143:]]