Seems 5.3 jailbreak is not working for most people...WHY?

Ok let me start with my story. I had a ATV 2 jail broken to 5.0.2 I believe. I did some house work and unplugged my router,ATV and tv. When I went to plug all abck in I noticed my ATV was missing the Firecore settings, PLEX, and XBMC logo…I thought it was odd so I decided to update the ATV to 5.3 to get the new features seeing that there was a teathered version for now. 

I go thru the process of jailbreaking after DFU process when the ITunes opens up and I guess it looks for a IPSW it just keeps thje finder/windows folder up, Am I suppose to select the IPSW? All the tutorials says you dont have to do anything that the process works by itself. I dont remember this issue before. I even tried to select it, It then says its going to restore in itunes. That process starts but does not finish. I get a error. 

Question Should Ituens be running the second you plug in the usb-micro or should I close itunes after it automacally opens? I know after DFU mode you leave it running but what about prior?

 

Anyone know whats going on? I am on the current version of MAC OSX and I did update my itunes to current version last night due to the ios7 upgrade. 

 

Anyone?

 

 

First thing, sometimes xbmc will disappear from the menu from time to time. Usually just unplugging the power will return xbmc and plex. If iTunes didn’t start the update, try plugging it back into your tv. Hopefully your 5.0.2 JB is still there. You don’t want update to 5.3 unless you have to, as it is tethered for now, possibly forever… 5.0.2 is untethered.

 

Well everything was missing like plex and all the other add ones. not just xbmc. So I upgraded to 5.3. I dont care if its tethred it only stays on that TV anyways so doesnt matter. 

 

Back to the reason why cant I jail break this version though?

 

Also Apple is gonna refresh all the apple tvs soon. Most will wanna upgrade and a new jailbreak will follow im guessing

I wouldn’t count on a JB for the upgraded firmware, but it could happen. You might have had a problem with iTunes being too busy because of people upgrading to iOS 7.0 in the last 2 days. I assume you’re using the newest Seas0npass. It should run the script and do everything after it asks for DFU. Before you try it again, I would try to save the shsh blobs for 5.0.2 first with iFaith.

 

 I would try to save the shsh blobs for 5.0.2 first with iFaith.”

 

i HAVE NO IDES WHAT THIS MEANS OR IS… HELP ME BUD

 

 

http://lmgtfy.com/?q=save+the+shsh+blobs

I wasn’t sure how much you knew abaout JB’ing a Apple TV 2. There aren’t any real benifits of upgrading to 5.3 except bluetooth keyboard support and being able to move icons and a few other things. XBMC works the same. I know I would trade you in a heartbeat my 5.3 tethered for a untethered 5.0.2. They are more valuable untethered, and there is no guarentee they will have a untethered 5.3 or higher. As far as using iFaith to back up your firmware signatures (blobs), you should so you can possibly downgrade your firmware to 5.0.2. Without doing that, you cannot downgrade. You will have to do some reading on this forum how to find and use iFaith, or just google it. Same with Seas0npass (zero, not a o). Try plugging it back in to your TV and see if XBMC and Plex show up again, if so, I would recommend you stay on 5.0.2 until a untethered JB for the current firmware is out. If you really don’t care if your Apple tv is tethered (you should) I’m sure someone online where you live will trade you for a properly JBen 5.3 for your 5.0.2 if you haven’t messed up the 5.0.2 by trying to update it.

And BTW I have JBen 3 Apple TV 2’s with Seas0npass in the last 2 weeks with no problems, so I’m not sure why you say it’s not working for most people in your subject line. Unless you’re not using Seas0npass.

 

Whats the big deal with 5.0.2 unteathered? 

 

Well I already updated my ATV on itunes to 5.3 am I screwed to go back on 5.0.2?  I never did a back up. From what I have goggled so far about shsh bloobs

There is no option to install Plex in 5.3 as Plex doesn’t run on iOS 6…  If it was missing from the main screen while it was running 5.0.2 you either do an unplug and reboot or failing re-install it from the ATV Flash maintenance menu.

I jailbroke two ATVs on 5.3 yesterday without any trouble, barring the proviso that I got 1648 errors a couple of times which I put down to latency issues on the Apple server.

EaglesNest-There’s nothing special about 5.0.2 except it’s untethered, which to most people is a bonus. If its tethered, if you have to move it to another TV or take it to a friends or have it freeze up, you have to hook it up to the laptop, to me and probably most people on this forum, try to keep their ATV untethered. iFaith will tell you if you have saved any blobs, if someone experienced had the ATV before you, there might be some saved. If you’re happy with 5.3 tethered (possibly forever) then no worries.

 

Well now im completly screwed itunes restored it to 6.0…■■■■

I try using tiny umbrella to find save SHSH but it seems my device is stuck and in recovery mode when I do it and I dont have mauch info or options

We I was able to downgrade to 5.2 Season Pass, But now my issue is the PLEX client. Thats oneo fmy favorite features about JB ATV. Is this not available on 5.2? This is getting to be a pain in ass. Never upgrading again.

Plex won’t install on iOS6.

Well l like I said I downgraded to 5.2 from season pass I tried 5.0.2 but would not work. So is 5.2 not able to get Plex client?