JB ATV 4.3.3 (2557) vs. aTV Flash Black - questions....


I have just bought a aTV 2 (black), which is jailbreaket with version 4.3 (2557) og there is only installed XMBC

I consider in buying “aTV Flash Black”, but have some questions before i make the move;

  1. Shall i update the Atv2 with SeasonPass?
  2. How does i at the moment make an backup of the existing firmware (so i can switch back if something goes wrong)?
  3. Which benefits does aTV Flash black give me? (its important that i get XMBC)

Any other good advises is appreciated.

Best regards


or can i simply just buy and then install ATV Flash Black over “the existing” XBMC etc.?

Doing so will update the Apple TV to a tethered jailbreak of iOS 5. Something I assume you wouldn’t want to do as 4.3 is an untethered jailbreak meaning you do not need the assistance of a computer to boot the device.



You will need to use iFaith (assuming you have a Windows computer) to pull the SHSH blobs from the device as Apple is no longer signing version 4.3 which means if you do not have the blobs you will not be able to return to that version.


aTV Flash is mostly Media Player (similar to XBMC without the plugin architecture) however it streamlines in the installation/update of a set of 3rd party applications. Note that if you purchase aTV Flash and are running version 5.0 on the Apple TV XBMC will not show. It is just a matter of time before fireCore add’s it to the available applications to install. 


This can cause problems if different versions are installed over top of each other. I would recommend removing XBMC before installing it through aTV Flash if you go that route.



Big thx. for your reply - much appreciated.

I will NOT update with SeasonPass, BUT i will make a backup of the firmware.

How do i uninstall XBMC from the aTV at present?

In advance - thx.



Regarding saving firmware;

I can’t get past step 1 - ifaith 1.4.2. It is asking me if I’m dumping an atv2 - I say yes - it tells me to plug in the atv2 via usb and to not hit start until the atv2 is blinking. There’s 1 longer blink followed by a quicker less bright blink. I hit start, it tells me to prepare to hit menu/play, I do, then release when asked, it blinks very rapidly for second and then at about 2 seconds left it says failed to enter DFU. What am I doing wrong?

Also tried with power connected?

tried that at least 15 times, with and without powercable attachted?

Do nothing with your remote before you press start, then follow instructions. Try couple times and you will get it working. Make sure your cable is connected without any hubs.  

if you want to install atvflash and reinstall xbmc you do not need to play with shsh blobs and rejailbreak.

just install atvflash on top.

P.S. you could be surprised that your shsh blobs were saved on cydia by 1st  owner.

Thx. for your reply


I wait and see if i take the step in buying and installing Atv Flash - i have xmbc now…

But thx.

end of story.