Could not open dir [smb://name].Reason: No such file of directory (2)

To all, I’m new to fireCore support and have tried to look for an answer to this error.  If the answer was answered in a past forum, please forgive me. I have been running atv flash (blk) for a while and love it.  I just installed ‘Media Player’ and would like to be able to access my movies on my external HDD that is plugged into my PC - with Windows Vista installed. When trying to add a ‘new share’, and test connection this is the error I receive: ! An error occurred. Could not open dir[smb://IRELAND-PC]. Reson: No such file of directory (2). This is what is entered in the ‘New Share’ criteria Share Type SMB Name IRELAND-PC Server IRELAND-PC Username (blank) Password (blank) Workgroup HOME Any help would be appreaciated, thank you.

Did you have any joy with this Chris? I’m having a similar problem.

Sorry, no answer for you but I wanted to chime in that I too get this error. However, I run a QNAP NAS. It only happens the first time I access the “root” share shown in Media Player. I hit MENU to clear/back out of the error then try again and it accesses the share just fine.

I’ve changed the share to use the name of the QNAP, as well as the IP address. Both yield the same result.

I am having the same problem since Monday. It was running really well until now. 

Thanks for the input gang,

I’m still struggeling and can’t figure it out.



Has anybody solved this problem?

I`ve got the same(((

Still nothing? I’m having this issue too. 

I signed up just to try to give you guys a possible solution :stuck_out_tongue:


First, make sure you have the folder actually shared. Secondly I usually go into advanced and set permissions and add the user group ‘Everybody’ (not sure if that is entirely necessary)

Probably most importantly though, on your OS, (I am assuming most of you are streaming from a current windows PC of some sort) Hit the start menu in the search box type ‘Sharing’ then select ‘Network and Sharing center’ then ‘Choose homegroup and sharing options’ then ‘Change advanced sharing options’ then Home and work, or public or maybe both, select the option near the bottom ‘Turn off Password protected sharing’


When that is set to ON, it requires a login before it will share any files, with it turned off, you can connect and just leave username and password blank.


If this helps even one person, I am glad I spent the time posting it :slight_smile:



These instructions are for Windows 7, I assume XP and Vista has a similar option though that you can get to through control panel or something.

I’ve had the same problem only for a brief moment if the Apple TV has been “logged into” a share for some time and then looses the connection. The solution for me, was to enter the “Maintenance”-menu and restart the Apple TV, then go in and re-test the connection and everything is fine again. Hope this helps!

Someone just asked the same thing in another thread, here’s how to setup an SMB share:

Thanks freebird this worked for me! You are the BEST!!!