Cant mount win7 shares (xbmc or media player) - Could not open dir[smb://name]

HI everyone,

I have waited months to finally find some time to jailbreak this ATV2 and run XBMC / media player on it as everyone online raves about it and I was happy to stop using my PS3 / xbox’s to stream media.


However upon jailbreaking with the latest tethered option and purchasing firecore to put on the ATV2, I’ve had nothing but no joy, and i’m starting to question the purchase.

I cannot mount any of my windows share drives on my home network, all the computers can see themselves fine, the PS3 can see everything fine even, however a direct SMB mount will not work within this media player on firecore.

I have turned off ‘all password’ requirements under advanced sharing, i’ve made sure ‘everybody’ has permissions along with an active user on the drives that I want to have shared. I’ve turned off all firewalls in the event they were stopping something and yet, I get the same issue.

Also attempted connectivity via IP or netbios name , no luck.


Error everytime : Could not open dir [smb://name]. Reason: No such file or directory(2).


I’m yet to find anything online or on this forum that leads to a fix for this problem, I"m not sure if this is a potential issue with this version of firecore that i’m running and the tethered jailbreak or not.

Any help on this matter would be greatly appreciated, i’m going out of my mind here trying to work out a solution and i’m limited in any further action that I can take :frowning:

Even though you turned off password requirements, try logging in using a user with administrator rights and password. Its worth a shot and worked recently for me.

I’m facing the same issue. 

I’m opened every and all my files are shared with everyone in my network. No passwords what so ever.

When I choose to read the library, I get Error 2 in XBMC. 

And I can’t do anything in Nito. It just has an upgrade option. 

And Media player as well, doesn’t detect anything. 
I even tried to restore my ATV2 and start the Jailbreak all over again but I can’t even do that !!! 


Is there really no support for Error 2? 

Is there something wrong with this latest version ? 


VERY frustrated . Regretting my purchase ! 



Update :

I’ve so far noticed, that this issue seems to only relate to my Windows 7 64bit machines (Home / Ultimate editions)

I powered up my older laptop running Windows 64 x32 and everything shared immediately, perfectly fine, all settings identical across all three computers. I almost gave up with this, uninstalled media player / xbmc via maintenance menu and going by other peoples recommendations have installed ‘Plex’, so far I"m having much better luck (albeit it different setup - it requires plex server to run on my windows machine, no big issue there for me) and its functioning well so far as its updating its metadata in the background.

I would very much like to knwo the issue with the above as I primarily wanted XBMC running.

My Firecore doesn’t have ‘Plex’ . Do I have to install it separately? 

Also I can’t uninstall anything through maintenance. How weird is that ? There’s no uninstall option !!! 

I actually tried over-writing the jailbreak but I couldn’t do that ! 

My ATV2 ran 5.0.1 and I installed the latest firecore . 

So basically I’m stuck with whatever there is on my firecore right now ! 

Are you sure?

Have you tried used ‘right’ on an installed item in the Maintenance menu?

I’m having a similar problem as the original poster.

I have an ATV2, a windows 7 PC and a QNAP NAS. I can log on to the sambashare on the NAS from the PC, and ATV2 with media player finds the NAS as a share, but when I enter the same username and password as I did from the PC I get "Could not open dir [smb://NAS1]. Reason: No such file or directory (2).

Is there any way to manually test this or see a log when connected to the ATV through SSH?

plex is a separate install, pretty straight forward, about 4 lines to type once you SSH into your apple TV2.

to uninstall, i couldnt find this either, in maintenance mode, push the right arrow/direction on the controller and it will come up with a ‘remove’ item menu

When you setup the SMB share in Media Player, enter this for the share name: IP/share and leave all the other fields blank.


Where Elements is the share name, and the IP is the machine it’s connected to. I’m using Win7 64bit with an external HD USB’d to my desktop, with the entire drive shared w/o a user/pass. I didn’t have to change any permissions with it setup like this.

Here’s a screenshot of window that displays the share name:




Thanks jonez, specifying the share solved my problem :slight_smile: i thought it only needed the server.

No problem, glad it worked for you. I did the same thing the first time I set mine up!

I have tried all of the above with no success. I’m beginning to feel this is a Mac only product. :frowning: