Can't tether boot jailbroken atv2 - 4.4.4

I successfully jailbroke my ATV 2 back in early January as a tethered boot.

Tonight I lost power to the ATV so  thought it would be a good idea to upgrade everything (Seasonpass, iTunes and ATV Flash).

The old version of Seasonpass was deleted, but I still have AppleTV2,1_4.4.4_9A406a_Restore.ipsw

Seasonpass is now 0.8.2 and ATVFlash was upgraded from 1.1.1 to 1.4

Now when I start Seasonpass the option to boot tethered is greyed out and selecting it gives the message:

The AppleTV2,1_4.4.4_9A406a firmware is untethered and does not require this process!

The Apple TV however still needs a tethered boot and shows the apple symbol with the cable icon on the TV.

Could someone please advise what steps I need to take so I can boot tethered?

Can I use the AppleTV2,1_4.4.4_9A406a_Restore.ipsw to jailbreak again if needed?
I have already tried option clicking on vreate IPSW and pointing to the one saved, but after DFU’ing the ATV iTunes just opens and sits on the ATV window with an option to wipe and restore to latest version.

You will need to backup your SHSH blobs before being able to flash the 4.4.4 iOS as the version is no longer being signed by Apple.

But its ALREADY jailbroken.

I just need Seas0npass to let me boot tethered.

How can I get this option back???

4.4.4 is now an untethered jailbreak that is why you no longer have the option. You would need to get a hold of a previous version that gave a tethered boot option.

If you can’t find it you could try redsn0w’s “just boot” option and see if it works.


Could anyone point me to a download link for Seas0npass 0.8.0 - I have tried mediafire wuth no luck.

U can’t find an archive of previous releases by Firec0re.