Latest Untethered SeasOnPass Tethered?

Have a mac with the latest itunes and ATV2 with the latest firmware. Using the latest SeasOnPass, I tried to jailbreak for the first time. The jailbreak seemed to go fine, with a success report at the end. However, on starting the ATV plugged in to the TV, I get an itunes logo and a USB cable image which I presume means “I want a tethered boot”. So, I tried a tethered boot, following the instructions provided and also get a success message upon which I remove the usb and insert the HDMI. No picture and after some minutes, I see the itunes logo and usb cable again.

Have I done something wrong or maybe misinterpreted what the itunes logo and usb image is telling me? No other errors reported and certainly no temporary FC logo on the ATV home page - don’t get that far.

Thanks

That strongly suggests you have not actually jailbroken with the latest SeasonPass. If you have it should not even offer you the tethered boot option.

OK, but why would it say “success” and then on boot display the itunes logo and USB cable image? Can’t get past that point as far as I can tell.

That is what you would expect if the wrong .ipsw file had been restored. Do you know what version of the .ipsw file you were restoring?

Thanks for the reply - I’ve the latest ATV2 sware from Apple and the latest SeasOnPass - created AppleTV2,1_5.0.2_9B830_Restore.ipsw.

This is correct, isn’t it? Flailing in the dark a bit!

Any ideas please? ATV2 not useable and not reply from the support ticket.

 

Thanks

What version of seas0npass you using?

Start over

Restore in iTines first so it’s fresh plug it into the TV and make sure everything starts up properly then run seas0npass again