aTV wouldn't boot

Not sure if this is Firecore related, but as it cost me another $29.99 I thought I post here anyway!

I went to watch a film on my aTV today (using Plex) and the aTV froze when trying to start the movie.  Left it a while but was stuck on the film info. page and none of the remote buttons worked, so I unplugged the aTV, left a minute and then plugged it back in.

The Apple logo was displayed and then disappeared but I was left with a blank screen and no start-up icons or menus were displayed (the aTV light was solid white and responded to the remote by flashing, but couldn’t get anything on the TV).  Tried this several times without any luck and was starting to worry that my aTV2 had died :frowning:

Thought I’d try connecting back up to my iMac and reapplying the jailbreak (can’t remember what version it was running, but haven’t done it since before 1.6) so downloaded the latest untethered SeasonPass.  This worked perfectly, and when plugged back in brought up the aTV set-up menu, so checked the network settings and went back to the iMac to reinstall the Firecore software.  I tried to use the atvflash-black.dmg I had saved on my NAS but it told me this was out of date (probably 1.6 which is the last time I downloaded, as I usually just update on the aTV) so logged into my Firecore account to download the latest version only to find this has expired!

Given how much I use my aTV I thought the $29.99 renewal was good value for money, although seem to remember when I bought it the first time it being described as a life-time purchase?  Anyway, this downloaded OK and installed back to the aTV without any problems.  I still need to set everything back up as it was, which will take a little while, but thought it was a strange coincidence it decided to break given my Firecore subscription had also conveniently lapsed, thus making Firecore another £29.99!

I think the Firecore software and support are excellent, and don’t really begrudge paying another $29.99 but the timing seems a little strange.  At least I don’t need another aTV!

It sounds like you may have been on a pretty old Apple TV version which may be the cause of some of the issues. Updating to the newer 5.0.2 would probably have been my recommendation. :)

Also, I’m happy to hear you took advantage of the renewal special, and here’s a bit of background on how our licenses work. The normal aTV Flash (black) license includes 1 year of updates, and this can be extended out during the checkout process for an additional cost, if desired. No matter which license option you choose the software will continue to work for as long as you have it installed, though you may not have access to some of the newer features if your license has expired.

Hope this helps.


Thanks for the quick reply!

Like I said, I really don’t begrudge paying another $29.99 for the aTV Black software as it turns the aTV2 into a really useful media device and the regular updates and excellent support from Firecore make it well worth the $59.94 i’ve paid over the last 3 years.

Everything’s set-up as it was, and seems to be running a little smoother too so reapplying the jailbreak and a fresh install of the software was probably long overdue.

Keep up the great work.




Great! :)