TV Flash Update- Problem!

I don’t know if anyone else has had this happen to them today, but I received notice from FireCore that TV Flash had an update…Well, I have 4 AT’v- 2 different locations, 2 different networks. All 4 are non-functional after the update (which said successful). None will boot up- they go on and off. My networks are fine, I even tried an ethernet connection. I am really bummed out about this… :frowning:

I have the same problem with my AppleTV 2nd gen.  I installed the v1.7 update, and the .dmg said it was successful.  Now the ATV win’t complete a boot – just keeps cycling with the screen flashing.  I sent email to support req how to fix, but no response yet. 

I can certainly sympathize with the frustration you’re going through right now… I spent the entire day trying to fix the problem without re-jailbreaking-- absolutely no luck. For those of us who had working jailbreaks (in my case Plex was not installed on any of my Apple TVs)–the updated version of TV flash will likely put you in the same boat…
I myself only updated after receiving an email from FireCore, saying an updated version was available for download…

To FireCore: I have nothing but respect and admiration for what you’ve done for the AppleTV and jailbreak–however-- it would be very helpful for those in our situation to post in your email that users need to completely remove Plex before attempting to upgrade TV Flash… I tried both SSH Ing in, and doing the update within maintenance- both scenarios (4 Apple TV’s/2 different networks)-- neither worked, and left my Apple TVs basically un-bootable (though not bricked).
The only solution I found work was to re-jailbreak- and prior to that doing a complete restore and update in iTunes. Make sure your computer and iTunes are completely up-to-date- use fresh versions of SeasonPass and TV Flash.
I should also add that I changed my root password after installing TV/and prior to installing anything in maintenance (ie: XBMC, Couch Surfer, etc)
This has been successful for me with two Apple TVs so far and I have two more I’m working
on now.

Btw- I would just like to add that in no way am I an expert or anything- and I’m definitely not saying this is the only way around this problem-- but it’s the only way that worked for me.

I cannot access my ATV at all, so I have no way to restore it to it’s original state.  I connected it to my iMac via USB, but iTunes doesn’t see it.  I tried to reload aTV Flash v1.16, but it failed with an indication the it is too old to be used.

I am in process of a re-jailbreak, and it appears to be working.  I will continue on to see if I can restore normal operation and report back with the results.

 

 

Okay, that happened to me on the 3rd one I did today- This* is what I did- could have been luck- Change USB cords (even if you’re sure the one you used works) Make sure iTunes has it’s latest update- I used Windows for the jailbreaks- Re-boot computer after update. Open iTunes- Plug Apple TV into different USB port if possible. I waited about a minute and then I plugged the power into the Apple TV (while it was connected with USB) really fast- Basically in and out. The lights on the Apple TV came on then and it installed new USB drivers. The SAME thing happened different ATV when jailbreaking…I plugged it in to get it in DFU and no lights…so I plugged into power again quickly, then unplugged power, and it easily was put in DFU (Menu/Home button 7-9 secs.)- Don’t give up- I hope it works for you. :slight_smile:

Also, IF you have the option, changing to a different computer can help too.

I think I am now OK.  I had to 1) restore the original code, 2) re-jailbreak, 3) install aTV Flash v1.7.  At steps 1 & 2, I ended with a 1602 error.  Moving to a different system or changing USB ports made no difference.  I only have one micro-USB, so I couldn’t substitute that.  I finally just ignored the error, verified operation after each step, and ended with my ATV2 working correctly with the new software installed.

If I find any new problems, I will add to this thread.  Otherwise, thanks for your help.  8)

I’m happy to hear you where successful. I don’t know how you install or if you install additional repositories in next XBMC, but I’ve been using “Fusion” installer and it works really well. It comes preloaded with a lot of the repositories (1 Channel, IceFilms, Live TV, Navi-X, etc) and plugins that are my favorites to use in XBMC- and they work well. If you’re interested in finding out how to add Fusion, or need help- just let me know.

More details on why this issue occurred, and a fix can be found here.

http://forum.firecore.com/topic/8560?page=2#comment-51721

James…

I’m sorry, but I found your comment both inaccurate and puzzling. As posted yesterday, I have 4 ATV’s. 4 ATV’s on separate networks (NONE of which had PLEX installed, though is was available to install in Maintenance) 2 Apple TV’s I tried to update within Maintenance- it crashed after the first install- subsequent loops after that. The next 2 were tried (1) by SSHing in- the other, TV Flash via the desktop.  All were unsuccessful and my only solution was restoring, updating firmware, and re-jailbreaking… All good now- LOTS of hassle.

Here’s the puzzling part…

  1. As mentioned, I have NEVER installed or enabled PLEX.

  2. Upon completion of my newest jailbreak (consistent with 4 Apple TV’s) There IS NO PLEX even listed or offered…? Your instructions to disable or not install it are odd… Or am I missing something?

Should also mention: “and after installing my updated TV Flash…”

 

Sorry

I did not have Plex installed, so it could not have been the cause of my problem.

I too did not have Plex installed.

Same issue here. I updated 3 of my Apple TVs through SSH using apt-get upgrade and then rebooted. 1 works just fine but 2 of them seem to have lost the jailbreak (SSH connections rejected, nothing but the default icons) but after rebooting several times everything came back up for both of them and it seems to be working. No idea if this is just a one off with the jailbreak or update related.

I also don’t have Plex installed and have been noticing some very strange behavior from my Apple TV.

The videos are often interrupted while being both streamed from my Mac or Internet (mostly podcast stuff), whereas I sometimes get an error message about the connection.

If I try to restart the Apple TV, it refuses to boot up, forcing me to re-jailbreak and reinstall everything. As a matter of fact I already reinstalled everything twice, and even though it seems to work for while, the strange behavior comes back after some time.

Any recommendations?

A few questions…

  1. Are you jailbreaking with Seas0nPass, or a different tool?
  2. Is the latest 5.0.2 software installed?

I am still running without problems, but this time only installed 3rd-party Media. The ATV2 does take much longer to boot, but that is the only issue I’m now experiencing.

My original failure to boot came after updating from aTV Flash v1.16 to v1.17, requiring restore of original software and firmware, rebreaking and install v1.17.  That says to me that v1.17 can’t be installed over top of v1.16.

Jailbreak with seas0nPass and the latest software available from you guys. And 5.0.2.

First time I got the issue happened when I did the update of the software via the apple TV directly. Then I decided to redo the Jailbreak and reinstall the software, so I downloaded everything yesterday again from FireCore and reinstalled.

It is running, but the error messages still come up every once in a while and to be honest I am afraid to reboot the Apple TV and maybe need to reinstall everything.

…I used SeasonPass & TV Flash. Tried both methods of update/same scenario.
I agree w/ above posts… I’ve tried everything I know has helped streams in the past-- it is not working as well… Streams are choppy. I have a very fast connection-- Hoping it will be working better soon. :confused: