Everything but Infuse can connect over SSL


Here, I run Jellyfin 10.8.10 (plugin in TrueNAS). I deployed a reverse proxy in front of it (HAProxy running in pfSense). The SSL certificate is from Let’s Encrypt and Qualys’s SSL Lab scanner confirmed my server is perfect (A).

When I connect the WebUI from Chrome, over SSL, using the DNS name pointing to my pfSense, it works. No port specified because it is listening on 443. HAProxy is the one connecting back over 8920.

When I connect the Jellyfin service from the Jellyfin client using the same DNS name and same default port 443 pointing to HAProxy, it works.

When I connect using Finamp for playing the music with the same settings, it works.

It is only when I try to connect my server from Infuse that it fails. The same iPad running all clients over the same WiFi connection will use my Jellyfin server properly as long as it connects to it with anything but Infuse.

Still, I like the Infuse client and would like to use it. For now, it can connect only if I point it directly to the Jellyfin Server over 8096 and the server does not require SSL. Anything else gives me a connection error ( Unable to connect to server.).

No matter it is Infuse iPad (Version 7.5.8 (7.5.4470)), Mac OS X (Version 7.5.8 (7.5.4470)) or AppleTV : they all do the same and all fail the same way.

Any idea what can be specific to Infuse for failing like this when everything else connect perfectly ?

Thanks in advance,

If you can replicate the error and then send in a report (and post the 5 digit code here) it will give us a better idea what may be causing the issue here.

For this, I opened Infuse, tried to connect, get the “Unable to connect” error message and then click the E-Mail us to generate the report. For the IOS email, I also added the screenshots from the working Jellyfin’s client and the error message from Infuse.

From Mac OS X the code is 72363
Ticket is 154915

From IOS, the code is V7RYW
Ticket is 154916


Support says that the password was not provided. If that is the case, it was not provided by the application to the server. I did entered my password. Multiple times and in different ways. Manually and pressing Enter at the end, manually and clicking next line to enter more informations ; with my password manager (EnPass.IO) ; I even created a user with a simple password that is very easy to enter ; … No luck. Nothing is working and Infuse always refuses to connect when other client softwares do it.

Any other idea ?

In your logs I see references to a server at with a .lan address extension, which is receiving an SSL error.

There are also 503 response errors when connecting to the server with a .ca address extension.

Some things I would recommend.

  1. Ensure the server address is entered without any leading http or https. EG. jellyfin.my-server.com instead of https://jellyfin.my-server.com
  2. Leave the Port field empty
  3. Leave the HTTPS option set to AUTO

With these settings, Infuse will automatically connect using SSL if possible (trying the various different ports Jellyfin uses), and will gracefully fall back to non-SSL if/when needed (this usually happens when connecting to a local device which has a self-signed certificate).

Today’s 7.6 update has a few improvements for HAProxy (and similar services) which can help with connection issues like this.

Can you try updating and see if this helps with the issue you were previously seeing?

Indeed, 7.6 connected instantly with only the DNS name, UID and Password. No need for advanced parameters or manual config of ports or anything else.

Thanks and congrats for your great player. Way better than others!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.