Infuse won't connect to Emby via HTTPS

Hey guys.

I’ve set up my own emby server online for the first time and connected it to Emby Connect. I can connect it to Infuse ok, however when I change Emby network settings to have HTTPS with an SSL, Infuse won’t connect to it. When I try to add the server it says it can’t connect.

I’ve tried using emby connect, and using the ‘other emby’ option, it always can’t connect to the server. As soon as change the settings to not require HTTPS secure connections, it works fine.

Any advice or help would be appreciated.

Are you using a custom port for secure connections?

Have you specified a port number under the advanced tab in the share settings in Infuse?

Hi James,

I’m using the default HTTPS port it offered which I have added to the advanced section on Infuse and said HTTPS yes.

Is this your own server? Is it local or remote? Does it have an SSL cert with a FQDN? iOS requires a valid SSL cert in order to use secure connections.

If you’re sure the SSL cert is set up correctly and it’s still not work, we can look further into this by sending in a report from your device (and posting the code here).

Hi James,

emby is installed on a third party remote server. The SSL is for a different domain to the server emby is installed on, the SSL was built using After enabling SSL and changing emby to require secure connections, I can still access it through the web port using the HTTPS port. Would that work?

I think if the public server address (the one you’re entering into Infuse) doesn’t match the address on the SSL cert, then that will be an issue.

iOS has gotten much more strict with how secure connections work in the last few versions of iOS, and mismatches like this can often times be blocked.

Thanks James that makes sense, is there any way to verify that’s 100% the case before I go exploring for alternative routes?

A quick test would be to plug in your server address at SSL Server Test (Powered by Qualys SSL Labs) and see what it says.

Unfortunately it won’t accept port numbers on that link.

The port would be required to connect to Emby, but the SSL is installed on the domain - so I think you can try leaving it off.

This works for me here when testing a remote Jellyfin server.