Default Audio Track

I have films that have both the original dolby digital 5.1 audio track and a mixed down AAC stereo track.

I had understood Infuse would always select the higher quality audio track, however it selects by default without fail the mixed down AAC stereo track rather than the dolby digital track.

How can I get Infuse to select the dolby digital 5.1 track by default?


Infuse will select audio tracks based on how they were ID tagged as default during the encoding process of the video file. For example if you were to use the mkvmerge application and open your MKV or MP4 file, you will see both tracks in there. Select the preferred track and you will notice on the right where it says “default track” flag, you would need to select YES for the track that you want Infuse to playback as the default track. If no default track is selected during your encoding process, Infuse and or any other player like VLC would just playback “track 1” by default.

Additionally, if you want Infuse to ignore the default flag and just choose the best track, you can change the Settings > Language > Audio option from Auto to your preferred language.


SoCalSean, James - thanks for the responses.

SoCalSean- I wasn’t aware of mkvmerge- thanks for the tip. Looking at some files using that they do indeed have the mixed down AAC track set as default.

James- I had Audio Language set to Auto. Changing this to English (United Kingdom) has solved my issue and the Dolby 5.1 track is now selected by default.

Thanks for the help- that has stopped me having to re-rip all my media!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.