Is there a way to select a default Audio track?

I noticed when playing my copy of Tarzan on my Apple TV that it selected the directors commentary DD Stereo track over the 5.1 audio track, is there a way to always select the best audio track (in this case the 5.1 audio track) by default?

You can adjust the preferred audio language in the Infuse > Settings menu. With this set, Infuse will try and enable a track matching the language you have selected.

If multiple matches are found (or no matches are found) for your preferred language, Infuse will use the highest quality audio track.

However, if your video has a default audio track flag set, Infuse will always use this - no matter what settings you have selected.

I would kindly like to ask if infuse can change the way this setting works .

If you have set default audio language to X, it’s because you want X. As it works now, if multiple matches are found for your preferred language, Infuse will use the highest quality audio track period (regardless of preferred language). It almost seems like a bug.

I will give an example:
I am Norwegian and have many animated movies for children, with multiple audio tracks. I, as an adult, often prefer to watch for example Disney movies with the original English audio track. The kids, on the other hand, prefer the Norwegian audio track.

A typical animated blu-ray movie that you buy in Norway comes with a DTS HD MA English audio track and a DTS or DD Norwegian audio track. DTS HD MA Norwegian audio track only appear in rare cases. For compability reasons, I typically add both DTS and DD audio tracks, in case the file should ever be used on a player without DTS license:

  1. DTS Norwegian
  2. DTS HD MA English
  3. DD Norwegian
  4. DD English

The problem is that in such cases Infuse will select DTS HD MA English, even though I have set Norwegian audio as default, because DTS HD MA English is of higher quality than DTS (non-HD) Norwegian. I do not quite understand the logic of this. Logic would have been that Infuse chose the hightest quality default language audio track (track 1 in the example above).

Thus, all of these movies start automatically with the English audio track. When the kids watch these movies, they have to change the audio track manually (by swiping down and so on) each and every time, which is a barrier to them and something I have to teach them (maybe not that easy for young children).

I will be really happy if Infuse could change this in an update soon.

Thanx :slight_smile:

I’m beginning to suspect there is something else going on. Let me explain.

In an attempt to bypass the problem I described in the post above, I modified a test file in MKVToolNix.
Output: Despicable Me (DTS HD MA English with no default or forced track flag, DTS Norwegian with both default and forced track flag).

Still Infuse chose to play the English audio track. I tried both “Norwegian Bokmål” and “auto” in the settings menu. Same result.

Then I tried something else that made me even more suspicious. I tested a file from a DVD (Winnie the Pooh: Springtime with ROO), which contains one DD English and one DD Norwegian audio track, both with the same quality (with the provisio that the norwegian track has slightly lower bitrate), as opposed to the example above where the English track had better quality. Still Infuse chose to play the English track, no matter what the settings and even if only the Norwegian track was marked as default.

Then I came to think of something else I’ve noticed, and that might be relevant for this. I have tried to set the metadata settings in Infuse to Norwegian too, and this doesn’t seem to work either. Regardless the settings, Infuse shows English Metadata only. Never Norwegian, even when Infuse’ metadata sources positivily confirms that a Norwegian version exists.

I’m starting to wonder if the problem here is actually that Infuse does not recognize neither Norwegian audio tracks nor metadata, even if they actually exist. And here’s my theory of why:

In Norway, we are impractical enough to have two official written languages. The main language is called “bokmål” (modern, urban) while the secondary is called “nynorsk” (traditional, rural). In Blu-rays and DVDs it’s always “bokmål” that’s used. In programs like MakeMKV, Handbrake, VLC Video Player and MKVToolNix, Norwegian subtitles are always named “Norwegian” (no mentioning “bokmål”). In Infuse, on the other hand, the language is named “Norwegian Bokmål” in the settings menu.

When “Norwegian” is set as default audio in VLC (Windows version), it always picks the right track, even if the file also contains an English track.

What I suspect now is that Infuse is looking for audio tracks named “Norwegian Bokmål”, something Infuse can not find because the track is actually named “Norwegian”. Then Infuse selects English audio track:

  1. “Norwegian bokmål” is chosen in Infuse settings.
  2. Infuse is looking for “Norwegian bokmål” audio tracks.
  3. Infuse is not recognising “Norwegian” audio tracks as the same as “Norwegian bokmål”.
  4. Infuse concludes that there’s no preferred audio track available.
  5. Infuse choses the alternative language (English in my case).
  6. English is being played.

As a result, there are only two ways to get Norwegian audio in Infuse at this time:

  1. By having Norwegian audio tracks only.
  2. By manually selecting the Norwegian audio track while the video is playing.

And Norwegian metadata is not an option that works at this time, probably for the same reason.

If I’m right, Infuse needs to change it’s settings so that it acknowledges “Norwegian” and “Norwegian Bokmål” as the same, or even better: change the settings so that the option is simply called “Norwegian” or “norsk” translated (as it is with “Swedish/svenska”, “Danish/dansk” etc.).

Can you please comment on this, James?

To investigate the case even further - Sherlock Holmes style :wink: - I checked with yet another file, this time with subtitles. The file contained one English, one Norwegian and one Swedish subtitle (VobSubs). I made sure none of the subtitles was set to default flag before adding it to Infuse.

Test 1: Infuse set to Norwegian Bokmål as default subtitle → fail (Infuse showed English subtitles, as English is the fallback language)
Test 2: Infuse set to English as default subtitle → pass
Test 3: Infuse set to Swedish as default subtitle → pass

The fact that Swedish (and English) works while Norwegian fails, undoubtedly strenghtens my theory.

It seems pretty clear Infuse don’t understand that “Norwegian” and “Norwegian Bokmål” are the same language. This applies to both audio tracks, metadata and subtitles.

I really hope Firecore can fix this bug as soon as possible.

Thanks for the detailed testing info.

It does seem like there may be issue in how Infuse is handling NO language variations. We’ll take a look and see if we can get this resolved.

Thank you so much! It would be awesome with a fix :slight_smile:

James, is it possible to provide a timetable for when this can be resolved? I hope it’s being prioritized, because it’s a pretty serious bug when one of the languages you claim is supported, just do not work with any of the default settings.

The error unfortunately reduces the overall impression of Infuse for Norwegian users. It would therefore be a relief with a solution.

I would think this is not a complicated thing to resolve technically, so will it be done in one of the closest updates?

Thanx in advance :slight_smile:

Im posting here to support what Videoman has already uncovered and Im also from Norway. Bought an Apple TV 4K tonight, downloaded Infuse 5 and setup network shares. No matter what I do, the videos default to English audio even if the Norwegian track was set as forced default in the MKV.
Use case is exactly the same too. Animated movies for my kids. I could teach them to switch language every time but thats too tedious when Im used to running Kodi on RPi3…
Any chance of a quick fix?

1 Like

I want to add to this apparent bug, with english commentary (2.0) tracks being selected over the default-flagged english audio (7.1) tracks. I have multiple .mkv videos with two english audio tracks, and on fresh files (no manual audio track selections in the infuse 5 tvOS app, so no file-specific infused-side “memory” of preferred tracks) the commentary track is always played as if it is default. I am playing from a Plex server with no preferred language set on the server side (or japanese is set as preferred, but it seems that has no effect at the infuse side), my AppleTV has “Default” as the preferred audio language, and Infuse has “Auto” as the preferred. I have verified that the 7.1 tracks are flagged as default using ffmpeg/ffprobe.

Moving default flags around in the file metadata, rescanning the library, and restarting the app/appleTV all seem to have no effect on audio track selection for multiple same-language tracks for me.

What’s strange is infuse does seem to be faithfully honoring subtitle default flags, just not audio.

Still curious about when we can expect a fix for the Norwegian language bug.

Yet another update and still no support for Norwegian language in Infuse, even if it’s a bug?

Is this bug fixed in 5.7 or is it never going to happen?

Just to follow-up on this, we have added a number of improvements to better handled cases like this and these changes will be available in the upcoming 5.7.3 which we hope to submit to Apple next week.

Thanks for your patience. :slight_smile:

Awesome! Hope it works?