5.2.1 Jailbreak Help


Quick question from a noob.

I’ve got a Jailbroken Apple TV already which was pretty easy to Jailbreak a while back.

A friend of mine has just bought an Apple TV 2 yesterday which has the new 5.2.1 firmware on and im getting an error message when trying to JB. I read on this forum that Apple have stopped signing the firmware now.

Is there nothing I can do to JB this ATV? will I ever be able to JB it?


At the moment there is nothing you can do to jailbreak the 5.2.1 release.   You can only jailbreak to earlier releases if you already have the relevant shsh blobs for your device.   However are you sure this is an ATV2 and not an ATV3 - I do not see how you could have just bought an ATV2 with the 5.2.1 firmware already on it!

Hopefully SeasonPass (oar an alternative jailbreaking tool) will be updated to handle the 5.2.1 release.  However when that might happen I have no idea.

Hi, thanks for the reply.

Thats what I thought but wanted to double check for him. He bought it off a friend who had obviously updated it straight away (as he never JB it).

It’s deffinately an ATV2 though.

Guess he will just have to sit and wait.

Any idea when this will be out as I bought a Apple TV 2 march 2011 but its on 5.2.1 so sad

I just traded a guy on crags list  bought an Apple TV3 then he gave me his appletv2.

I got home it was on 5.1.1 I couldnt jailbreak it.It gave me an error that I was not eligible for the firmware.

I knew right away Apple signed out their old IOS,because just couple days ago .

My other appleTV2…my daughters and mine downgraded to 5.0.2 ,I tried all  firmware nothing works better than a 5.0.2

But anyway,so like a damb ass I updated ,I thought it will be on 5.2, I forgot apple just release 5.2.1.

F**CK ME! I am so pissed I was going to sell it on ebay for $350 now  its worthless.

When are they going to come out with a jailbreak to fix this?

Why does apple always care,if we jailbreak out devices? we own our devices ,we can do whatever we like with them.

Plus who buys movies these days…I can get any movie I want from pirate bay.

F**CKING apple.ass wholes



Calm down buddy…

Time to get Android or OUYA


Just got my brothers Apple TV 3 it’s on 5.2 can I jailbreak this please advise

Apple TV3 Jailbreak is not available and also Apple TV 2 with Firmware 5.2.1 too…

Could someone tell me what versions of Apple TV are available to jailbreak so I can source 1 please thanks site

Apple TV2 Model MC572 but don’t buy firmware 5.2.1. This will cost you bundle but do look around Android stick or TV set top box or Tronsmart or Piovs


Tronsmart Android TV Box working awesome and kick ass Apple TV2.

I was able to take a 5.2.1 atv2 and downgrade it to a jail broken 4.4.2 tethered boot release from great help on these forums. If interested, take a look. No shsh blobs required.

I just hope fire core can do it again apple is so slick none of the firmware are on their server except for the latest 1 which is 5.2.1

i recently updated to 5.2.1 and have spent 4 days trying to restore,getting all sorts of error codes, i eventually downloaded ifaith and luckily i had saved (without knowing) shsh blobs 5.0,2 and 5.1.1 i faith retrieved both and i saved to my desktop.i then ran snowbreeze and snowbreeze downloaded the ipsw 5.0.2 from the net,it then requested do i want to use the shsh blob, i then directed it to “my desktop” 5.0.2 shsh (ifaith saved blob) it then created a snowbreeze “signed” ipsw ran shift restore in itunes and back up and running.

hope this helps,i can be emailed if required

anyone in the boro i may be able to assist

Dude borojim cracked it! Basically I upgraded MY ATV2 to utilize to my new wi-fi keyboard not realizing Apple had released the new update!! = NOT A HAPPY BUNNY!

Just fixed it right now following borojim’s way, WORKED! as long as you’ve got shsh blobs 5.0.2 you’re cool

Got blobs? do this…

  1. Download iFaith, of the 4 options -  click “Buildsigned IPSW w/Blobs”

Next Click “Browse for blobs” - pop-up window should take you straight to the file you want. (atv2 5.0.2 shsh)- click it.

  1. Once its created download Sn0wbreeze and open it, then either click browse ISPW, or download firmwares.(depending if you already have a saved 5.0.2 IPSW or not?, if not don’t worry just download it)

After it does it’s thing, if it says verified, you’re all good.

  1. Next click the blue arrow bottom right, then click “iFaith Mode” (This will combine blobs with IPSW and leave the result on your desktop)

  2. Once process complete connect ATV to computer, go to iTunes, hold shift and click restore.

  3. Pray!

  4. If it says it has restored to factory settings connect ATV to your TV, you should have NitoTV icon, open Nito, Install XBMC, Voila!

Sorry Firecore if this is not what you wanna see but Apple has really blindsided us with this one, and i’m sorry but for now needs must my friends!

Rest assured as soon as you work out and release the new seas0npass JB software i’ll use it, I have used FC from the beginning but for now I need my XBMC and this is the ONLY WAY THAT WORKS!!!

Cheers borojim.

Hey Guys, 


I’ve tried the above method with some success. However in iTunes I keep getting a 1600 or 1604 error and my ATV 2 just keeps blinking once I plug in the power cable. Has anyone else encountered similar issues? 

UpyouAPPLE—glad you got your Atv back,well described

Darryl i suggest you follow the exact method both myself and UpyourAPPLE used but without the power cord plugged in? for some reason it did not work on my laptop but worked 1st time on my desktop.also worth trying another Usb cable

good luck BoroJim

borojim, thanks for your suggestion. I need to clarify I only plugin my power cord after I complete the iTunes update. I plugin the power cord and the hdmi cable to see what I get. My issue is that my error occurs during iTunes. Any idea, I’m using a 5.0.2 blobs.


 can anybody tell me how could I upgrade my appletv 2 to 5.2.1  ? is that trough iTunes ? if ill buy upgraded tvflash black may I fix this problem with firmware??

When Jailbreaking, the power cord is effectively useless. You will never do it successfully if the power cord is plugged in, the only real time you need the power cord is when/if you plug the ATV2 into your computer and you cannot see the flashing light at the front of the ATV2. If this happens plug the power cord in, the light will start flashing, remove the power cord again. DONE.


Elgar, if you want to upgrade your jailbroken ATV2 to 5.2.1 then be prepared for a stressful few days trying to reverse that move, if you want a jail broken device then you’ll have to join the back if the queue, and read this post from the beginning!! My advice is wait until FC bring out a new Seas0npass JB before you do anything. It will save you a few grey hairs!!