your device is running low on memory

Ran into my first problem since the beta 6. While about 45 minutes into a 2 hour film I got a message on my screen -" your device is running low on memory". Running from my external drive (NAS) connected to my Apple Extreme.

Any suggestions. When attempting to play again, it is a Video_TS folder, the film went back to main menu, not resume playing.

Tried twice, same message appeared.

I have played other videos, about 90 min and 75 minutes long, no problem.

(I only have XBMC not using at present; Nito, CouchSurfer-rarely use and Last FM installed)

New problem with new media player. Attempted to watch a mkv file and 2 minutes in got the your device is low on memory. The previous post and this post are in relation to full length films. Any suggestions.

Your best option will be to submit a bug report so we can track down what’s going on.

What ever happened here? Having the same issues with the new release.

Having this issue when streaming from WHS2011 but not my NAS??? Got 8GB in the WHS and only 1GB in the NAS… I assume it is related to ATV2 memory, not server/ NAS memory. This only happens to me when playing 1080p and 720p movies and only through media player. I installed Plex and it didn’t happen but I prefer the simplicity of a media player, that and the fact plex meta data fetch is crap and takes far to long to manually change all the names. This happened particularly with the kids show pepper pig… some of the names and cover art it picked up were colourful to say the least; there were horrors, thrillers and porn in place of this cartoon and the cover art was everywhere! my son’s eyes almost popped out of his head when I discovered this! lol

Any help would be great

In addition to Media Player, do you have any other 3rd party software installed (Plex, or things like Main Menu Weather, Main Menu Slideshows that were installed via nitoTV)?

I got Plex installed.

Hi James, I had Plex installed also but not NitoTV, I tried to uninstall Plex but it simply wouldn’t remove from the “installed” status under the maintenance TAB although it wasn’t showing up in the main menu area. I have only just recently upgraded to the 1.0 release over the weekend and have not reinstalled Plex so will have to wait until this weekend to check if the new release has fixed it or not.


In saying that, I don’t think it is a Plex issue although it may seem like it is as I was having this issue prior to installing Plex. In fact this issue is the reason I installed Plex in the first place as it didn’t seem to happen during playback through Plex and the WHS.



I get this when I try to do a Full backup, therefore I am unable to accomplish the backup. Apple TV software version 4.3 (2557), latest aTV Flash and Media Player installed, nothing else.


Any news? Should I delete Plex?


Well I updated mine to the newest version then re-jail broke it etc but didn’t reinstall Plex and so far I haven’t had any issues (or should I say my wife hasn’t.) 

wanted to re jailbreak it but not getting it into DFU mode. tried all the tricks given here but still wont´work. anyone know why its not working.


EDIT: Never mind got it

OK did a rebreak and reinstalled the newest version ATV. LEft out PLEX this time but still have the same problem streaming mkv file from my PC. still get the message device is running low on mem.

Have the same problem!!

Memory issue when trying to watch a 350mb avi from my NAS. What’s wrong with ver 1.0?

Same here!! Can’t even do a restore as it’s can’t download the software from Apple!!  I received a ‘critical update’ today via the maintanence menu so maybe this is anything to do with it?

Forgot to say, it wouldn’t uninstall programs either.


One thing I did do though, as mentioned previously, was try to do a back-up to Apple.  Maybe that’s the reason why.


That said, I’ve also used Plex a lot over the weekend, for the first time, to listen to music.


I’ve now re-done the jailbreak.

Great now I can´t see a picture when I use my IPAD2 and stream Youtube on my Samsung via the ATV. I can hear it but I can´t see a picture.


What´s going on with this new release???

Any news. It´s a little frustating.

Yeah would appreciate an answer from fire core here… Logs sent a week ago

I really like the product!! But the support REALLY needs to improve.