Xvid and Divx audio problem

All my Xvid and Divx files worked prior to 4.1. Audio is in AC3 format. Now under 4.1, all is get is loud static. Have updated all players and codecs, what next?

Is your AppleTV connected to a AV receiver that supports 5.1 sound? If not, the ‘AC3 Passthrough’ option (located in Maintenance --> Settings or the respective menu you are using) should be disabled.

Yes I use an AV receiver that supports 5.1. I have tried enabling and disabling these selections but the loud screaching remains. Have done reboot after each change. Have reinstalled perian and other codecs, and now I have no video, on all of my vids. WTF. Honestly, whoever wrote this versions should be sacked. I would expect this from an open source product, but not one I’ve paid for. What the hell is going on at firecore?

You may try removing and re-installing the Perian codecs. This can be done through the Maintenance --> Install Extras menu as described here: http://wiki.atvflash.com/index.php?title=Maintenance_Plugin#Install.2C_Update_and_Remove

Ok, I’ve updated ATV to 3.0.2 and downloaded 4.1.1 and patch sticked my ATV. Video returned but audio on Xvid still has loud static. I removed and reinstalled perian and the problem remains. One thing I did discover, I could play the Xvid in XBMC as long as I turned audio in system settings to analogue instead of digital. I am using a digital AV receiver with HDMI to TV and optical audio cable to AV receiver. Again, this never happened before the 4.1 update (same file played perfectly under 3.X). My only guess is that perian 1.2.1 has a conflict with ATV Flash 4.1 or there is a bug. I’ve exhausted all attempts to return my Xvid audio to normal, but have failed. It must be a software issue, not a settings issue.

I also have similar audio static problem, divx and xvid movies play fine on pc , but when copied into movies folder
via windows explorer onto my apple tv I get an awful static sound on some films , tried reinstalling all software and no
different , any ideas ??? cheers , paul

The echo here is here is incredible. Nobody seems to even give a f@#k in this place. Problem still persists and a careless attitude from the support crew leaves me cold. Thanks for nothing (I was going to put an expletive here, but you can guess which one suits).

Well seeing as nobody cares to give an answer to this, I have found it is specifically an AC3 audio format problem (yes I tried enabling and disabling AC3 playthru), but seeing as these files ran flawlessly before, I can’t see why no-one else has found this problem. And before I get the, “check for updates” auto response, I’d like to point out I have exhausted all avenues and tried everything I can think of, short of re-encoding my vids in another format, but why should I have to do that when it all worked fine before, and as it states on their website, these formats ARE supposed to be supported. Short of rewriting the bloody code myself, I can only gather the mods have no idea or don’t give a fuck. Thanks, how special do I feel??!!!

Which menu are you using to play the files? For deeper troubleshooting your best option may be to send an email here: http://www.atvflash.com/contact.php

I have tried all menus, Nito, boxee and regulars files menu. As I said, I have tried ALL options. I’m not a person who gives up easily. I honestly believe it’s a perian problem as this did not happen on previous versions of atvflash or the older version of perian.

I too have the same problem and have tried all the same solutions. Only a few movies though have the loud noise, not all. was there ever a solution?

I found out Xvid or Divx movies with AC3 audio files are the issue. I haven’t been able to solve it by changing the settings but I succeeded in being able to play them using the boxee movie player. I had to change the audio settings in boxee to make it work. I think it’s a perian plugin problem but that’s just an educated guess.

Same issue, and brand new for me, too. Can't figure out what's causing it, or how to fix it. Sound works perfectly normally when streaming through TiVo. Answers greatly appreciated.

Faced absolutely the same problem. Boxee helps, but I like to use Media Player. It seems that the problem appeared after latest codecs update.

It looks like there is a "bug" in nitoTV. It sends an incorrect signal to receiver to change for AC3 mode. I found a temporary  solution; at least it works on my device. 

1. I switch on my device; 2. go to nitoTV and open any AC3 video; it plays, means video appears, but no sound just a loud static; 3. then I close nitoTV and open Sapphire and play the same file, what I tried to play in nitoTV; with Sapphire it plays in correct way and receiver changes to AC3 mode without any problems; 4. then I go back to nitoTV, open any video files and now it works perfectly - the receiver change audio mode in correct way. Unfortunately, it solve the problem just until next reboot of device. So, looking forward to fix!

Not sure if my problem is the same but I recently purchased the ATV Flash (within last week) and I'm not able to view my DVD movies due to a very loud annoying noise.  The best way to describe the noise is a very loud metal sprocket that is grinding or slipping.

I converted the DVD using Ripit, no problems at all.  Plays perfectly on my Macbook Pro, with absolutely no audio problems at all. 

 

 It seems to be only Nito Tv issue as AC3 audio is fine through Boxee  /  XMBC. The issue still hasn't been resolved in the latest version 4.2.

I Have the same problem here ! :S

Only solution i discoverd is that i turned off the digital audio output in boxee/xmbc and turned analog on.. this way stereo sound is going through my optical cable and my a/v receiver to my speakers

i'm sure its a software issue.. so pleaze FIX IT FAST !!! i want to enjoy my movies in 5.1 surround !!

 

Im still having problems with this, anybody got a solution yet ?

Quite frustrating :(

Hi All,

I have had the same problems and solved it by specifying one of Quicktime or MPlayer rather than mix and making another change with the AC3 and something else.  However, that is a side issue as we still suffer from unstable playback, all very annoying.

Anyway, a quick and easy fix I have been using of late is to convert all files I have downloaded and want to watch on my TV, as oposed to the computer, into the iTunes format by using VUZE (http://www.vuze.com/), a bitorrent client, and then watching through movies on the standard ATV platform.  iTunes automatically uploads the converted files to your ATV once completed.

Works for me and the conversion is quick and easy.

Until the next ATVFlash update, cheers!