XBMC will NOT work. Keep getting "Error: Cannot launch XBMC/Boxee from path: ..."

I’ve updated the settings.  Installed all the ATV Flash updates necessary.  I’ve installed Dharma, still doesn’t work.  I’ve installed Eden, still doesn’t work.  The other option is “Rev. 20120430”, which is some kind of update?  But that does nothing as well.

I’ve started from scratch–I put my ATV silver back to the factory settings.  Updated, reinstalled ATV Flash, updated from there.  I though that might solve the problem but no, XBMC simply will not load.  I always get “Error: Cannot launch XMBC/Boxee from path: /Applications/Boxee.app/Contents/MacOS/XBMC”.  At my wit’s end, don’t know how to proceed.

Same here. That’s all I wanted it for :frowning:

Had previously had this all set-up using atvusb-creator and running great - thought I’d try ATV Flash as it had a few features on I’d like to try and now the thing I use most, XBMC, isn’t working.

Not feeling I am getting much value out of my £33.50, at all, as I had to go back to using atvusb-creator.

How long does it normally take for support to get back to you on these things?

 

 

June 22: got the same error. Submitted a problem report Friday. Hope to hear by end of next week.bany other suggestions as to what one could try?

I had the same issue with my ATV

Updated the launcher to latest.Worked straight after the update had been downloaded.

go into ATV Menu ,XBMC , Setting then voila!

Thanks fuglife1981.  I am having the same problem as well.

 

For the newbies to aTVFlash and XBMC, would you be able to tells us where and how to update launcher?

 

Appreciate it!

 

After getting yesterday’s latest version 4.5 I received the same error, what I did was Re do the Factory Restore, used the Flash Drive recovery software to format my flash drive, re-download 4.5 in a new folder on my desktop and start fresh. After doing this, worked like a charm, even added a few add-on.

This one is driving me crazy! I have Apple OS 3.0.2 installed and aTV Flash 4.5.

I followed all pre-install steps to install NitoTV and to run the Smart Installer.

But each time I want to start the XBMC 11 download I get the error “An error occurred”.

Is there any way to do the XBMC download+install steps manually via FTP/SSH???

Or is there any log that shows me WHY the download fails???

Finally I solved the XBMC-installation via a couple of simple commands.

I started an SSH-client and connected to the AppleTV via user=frontrow, pw=frontrow and

then I just executed the following command-sequence:

wget http://mirrors.xbmc.org/releases/osx/xbmc-11.0.dmg
wget http://atv-xbmc-launcher.googlecode.com/svn/tags/ul-info/scripts/xbmc-11.0_update.sh
sudo sh xbmc-11.0_update.sh xbmc-11.0.dmg

…and then it worked immediately!

2 Likes

yay   thank you CG

if its the first time loading and using xbmc it won’t start untill you download a version. so in the xbmc menu it will list “xbmc” first right under that will be “downloads” then “settings” and whatever else… go to downloads first. pick one you want and click it. it will download and you should be ok

Hey guys! Sorry to bother, does anyone have a copy of xbmc-11.0_update.sh ? Please I can’t find it anywhere, I would really appreciate it! Thank you very much!!

HOWTO: XBMC INSTALL
get the xbmc-11.0.dmg from:

ftp://mirror.optus.net/.mirror2/xbmc/releases/osx/i386/old/xbmc-11.0.dmg

Then you can copy it in path:

/Users/frontrow/Library/Caches/XBMCLauncherDownloads/xbmc-11.0_update.download

Next, ssh into AppleTV and cd to above path then chmod the install script in
same location to make it executable:

chmod ugo+x xbmc-11.0_update.sh

Then execute the script with the dmg file as the argument:

./xbmc-11.0_update.sh xbmc-11.0.dmg

You didn’t even read my question, keep going

the script is already there… you just have to meddle with it… there is no updated one that i have been able to find…

My response is a general one that pertains not just to your question, but to others who are starting from scratch…

No, the script is a spare .sh file which is not at the drive, (google link where you could originally download it, is now dead).

So when you cd to the path /Users/frontrow/Library/Caches/XBMCLauncherDownloads/xbmc-11.0_update.download, you see nothing there?

Try and run the xmbc installer again from maintenance menu…

#!/bin/sh

DISKIMAGE=$1

echo “Installing from diskimage $DISKIMAGE”

check that disk-image exists

if [ -e $DISKIMAGE ]; then
PW=“frontrow”

check and store OSBoot read/write settings

REMOUNT=0

Check if / is mounted read only

if mount | grep ’ on / ’ | grep -q ‘read-only’; then
REMOUNT=1
echo $PW | sudo -S /sbin/mount -uw /
fi

install xbmc app

echo $PW | sudo -S hdiutil attach $DISKIMAGE
#remove old app
echo $PW | sudo -S rm -r /Applications/XBMC.app
echo $PW | sudo -S rm -r /Users/frontrow/Applications/XBMC.app
#copy new one
mkdir -p /Users/frontrow/Applications
cp -r /Volumes/XBMC/XBMC.app /Users/frontrow/Applications/
echo $PW | sudo -S hdiutil detach /Volumes/XBMC
#symlink to /Applications
echo $PW | sudo -S ln -s /Users/frontrow/Applications/XBMC.app /Applications/

handle any post-install items here

perl to bash convertion of postflight script pending

if [ ! -d /Users/frontrow/Movies ]; then
echo $PW | sudo -S mkdir /Users/frontrow/Movies
echo $PW | sudo -S chown frontrow:frontrow /Users/frontrow/Movies
fi
if [ ! -d “/Users/frontrow/Video Playlists” ]; then
echo $PW | sudo -S mkdir “/Users/frontrow/Video Playlists”
echo $PW | sudo -S chown frontrow:frontrow “/Users/frontrow/Video Playlists”
fi
if [ ! -d /Users/frontrow/Music ]; then
echo $PW | sudo -S mkdir /Users/frontrow/Music
echo $PW | sudo -S chown frontrow:frontrow /Users/frontrow/Music
fi
if [ ! -d “/Users/frontrow/Music Playlists” ]; then
echo $PW | sudo -S mkdir “/Users/frontrow/Music Playlists”
echo $PW | sudo -S chown frontrow:frontrow “/Users/frontrow/Music Playlists”
fi
if [ ! -d /Users/frontrow/Pictures ]; then
echo $PW | sudo -S mkdir /Users/frontrow/Pictures
echo $PW | sudo -S chown frontrow:frontrow /Users/frontrow/Pictures
fi

if [ ! -d /Users/frontrow/Library/Logs ]; then
echo $PW | sudo -S mkdir -p /Users/frontrow/Library/Logs
echo $PW | sudo -S chown frontrow:frontrow /Users/frontrow/Library/Logs
fi

if [ ! -d “/Users/frontrow/Library/Application Support/XBMC/userdata/” ]; then
mkdir -p “/Users/frontrow/Library/Application Support/XBMC/userdata/”
fi

#add advancedsettings for better h.264 experience
AVDSETTINGS_PATH="/Users/frontrow/Library/Application Support/XBMC/userdata/advancedsettings.xml"
if [ ! -e “$AVDSETTINGS_PATH” ]; then
echo “8” >> “$AVDSETTINGS_PATH”
else
#fix typo that was present up to r212
sed -e s/sliploopfilter/skiploopfilter/g -i “” “$AVDSETTINGS_PATH”
fi

#d4rk said this is already done in installer; do it anyway, can’t hurt
echo $PW | sudo -S chown -R frontrow “/Users/frontrow/Library/Application Support/XBMC”
if [ -e “/Users/frontrow/Library/Application Support/Remote Buddy” ]; then
echo $PW | sudo -S chown -R frontrow “/Users/frontrow/Library/Application Support/Remote Buddy”
fi

#delete xbmchelper it’s not used on ATV
if [ -e /Users/frontrow/Applications/XBMC.app/Contents/Resources/XBMC/tools/osx/XBMCHelper ]; then
echo $PW | sudo -S rm /Users/frontrow/Applications/XBMC.app/Contents/Resources/XBMC/tools/osx/XBMCHelper
fi

clean up

if [ -h /Users/frontrow/Movies/XBMC ]; then
# something makes this symlink during install so zap it.
echo $PW | sudo -S rm /Users/frontrow/Movies/XBMC
fi

#sync to disk, just in case…
/bin/sync

restore OSBoot read/write settings

if [ “$REMOUNT” = “1” ]; then
echo $PW | sudo -S /sbin/mount -ur /
fi

exit 0
fi

echo “Failed to find diskimage $DISKIMAGE”
exit -1

angegebenen Internetseiten sind nicht mehr erreichbar, somit kann XBMC per ssh über Terminal nicht installiert werden. Ich versuche verzweifelt XBMC im ATV silver
(aTVFlash-XBMC) zu aktivieren. Bisher ohne Erfolg. Der Support von FireCore ignoriert meine Anfragen. Ich bin im Moment ratlos und am Verzweifeln.

hi Guys,
can no longer open xbmc. the support of firecore does not respond to my requests. I have atv flash xbmc. can someone step me at step
describe how I can fix the error? Thanks for the support.
Best regards

HJK