XBMC will not play mkv files

Updated to new firmware and XBMC wont plat 720 mkv but play avis no problem, tried everything out there how tos only thing i havnt done is downgrade.

Plex for windows works great little more setting up but plays everything.

Guess i need to wait for XBMC update.

I’m having the same problem :frowning:

When i start a movie, it starts “working” in the right lower corner, then black screen. and the back out in the atv start menu…

Need help…

The are messages on the XBMC forum saying that XBMC will not work if the FireCore Media player is installed.    Also, XBMC does not appear to get on well with the latest Apple firmware releases based on iOS 4.3.

I haven’t seen this yet, link please?

Anyone using the XBMC nightly builds has had success with the issues mentioned. I would try that first.

I haven’t seen this yet, link please? Anyone using the XBMC nightly builds has had success with the issues mentioned. I would try that first.[/quote]

That is obsolete information now.   Beta 5 of the FireCore software solved the incompatibility issues.

I haven’t seen this yet, link please? Anyone using the XBMC nightly builds has had success with the issues mentioned. I would try that first.[/quote]

That is obsolete information now.   Beta 5 of the FireCore software solved the incompatibility issues.[/quote]

 

That is what I thought, imagine my confusion to see there was an issue, still!

Looking forward to hearing the solution! Nearly all my files are in .MKV format and play fine with XBMC on my PC. I switched to an Apple TV to make things easier for my other half - having the PC hooked through the receiver was causing her too many issues. The Apple TV was meant to make things better but now I can’t access 90% of my media!

Ok, so what versions of the software are you using? Beta 5 of aTVFlash seems to have the issue resolved and XBMC does work with the nightly builds… Are we talking accessing .MKV files through a network share or something else?

I have the same problem. Exerything is up to date, but if I start a .mkv file it will gone back to Apple desktop screen. Any idea?

So are you using the aTVFlash version of XBMC or the nightly builds? If not you should be…

See how to seup XBMC nightly build info here…

So are you using the aTVFlash version of XBMC or the nightly builds? If not you should be…

See how to seup XBMC nightly build info here…[/quote]

Thank you. Now its working fine.

So are you using the aTVFlash version of XBMC or the nightly builds? If not you should be…

See how to seup XBMC nightly build info here…[/quote]

Thanks Quinn, worked great for me (ATV2 on 4.2.2)