XBMC SMB shares not working

Anyone else having issues with SMB shares in XBMC? I get “Operation Timed Out” whether I browse or set up the source.xml file manually. No joy. I followed these instructions for XBMC install. http://wiki.xbmc.org/index.php?title=HOW-TO:Install_XBMC_on_Apple_TV_2#ATV_5.x

Anyone have any ideas? The log shows nothing of interest. Just says couldn;t connect.

Can I go back to an old release of XBMC somehow? If so, can someone provide some instructions on how to do that? I know how to SSH into it and all that jazz.

Thanks

I attempted the same thing with an SMB share on my windows XP box and it worked.

So this is a problem with Windows 7 SMB shares (x64).  Crap. My Windows 7 server is where I host all my content. Any ideas? The Windows 7 shares are set up with no passwords. They work properly from other Windows boxes.

Off jailBreaking topic guys…

See http://forum.xbmc.org/showthread.php?tid=124250

 

Use NFS is possible. Samba has quite much overhead, ATV2 work much faster with NFS.

 

After some further research, I found this and it worked.

On the Windows 7 box, use regedit to change the following 2 keys:

Set the following registry key to ’1′: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and

set the following registry key to ’3′: HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

After making these changes and restarting, I can browser Windows 7 shares. The weird thing is this. I put the values back to 0 and 1 and restarted. I can STILL browse the shares. Maybe just rebooting the Windows 7 box fixed something. Strange though because when it was NOT working from ATV, I could browse the shares properly from other Windows machines. Oh well. Maybe the above will help someone