XBMC ok in ATV 1st gen not so ok in ATV2

I’ve been able for some time successfully to play movies via XBMC on my first generation ATV.  All video is accessed via an SMB mount to my unRAID server.  But…

 

I’ve never been able to get XBMC to play video on my ATV2 (iOS 4.2.1) though all movies and their folders are, of course, visible. It pauses a bit, then flips me back out to the main screen.  

 

Suggestions?  

 

BTW, some have suggested that the Media Player in the most recent update is another option, but one thing I kinda like about XBMC is the downloadable and installable subtitles option.

 

thanks

I believe the ‘flipping out’ is due to XBMC being interrupted by software update requests. The easiest fix is to install Updatebegone from NitoTV.

I installed updatebegone.  I also re-jailbroke to the latest, installed XBMC, etc.  Unfortunately i get the same pattern:  click Play, the Working arrow spins for about 10-15 seconds, then xbmc crashes.  I did, though, attempt to change some of xbmc’s settings and when I unchecked Enable Hardware acceleration i had better luck:  now the video starts, but there is considerable buffering and the sound output is static-like noise.  I’m making progress…

Oh, one other thing, I did try to run the latest nightly build by following this post  http://forum.xbmc.org/showpost.php?p=768428&postcount=85  but it appears that the server I was trying to reach was down(?)

try it again… or manually download it from the link in the post :

4) Install the latest nightly build from xbmc:
a - $ wget http://hadm.net/~keith/xbmc_atv2/latest_atv2.deb

it is working now anyway…

ftp it into your updates folder and follow the instructions to apply the latest build.

XBMC SMB shares working in latest build May 7th… http://forum.xbmc.org/showpost.php?p=768428&postcount=85 20 minute update.

This does not seem likes it’s triggered by the updates. My hunch is your files are not encoded with H.264.  The ATV2 only kicks in with hardware accelration when files encoded with H.264 are played. Try a product like handbrake on a file or two and see if it makes a difference. Note that, even with H.264 encoding, files that are in the size range of about 10GB per hour of playable content tend to choke the system, H.264 or not.  

these are all H264 ripped in Handbrake using settings slightly modified from the ATV (1st gen) presets.  again, they’ve played pretty flawlessly on ATV1

did try to install latest nightly, .deb file downloads but attempt to install it comes up with “No such file or directory”.  same error when attempting to install from local (Downloads) path.

Is it possible to install Nightly Build using a windows pc?

 

 

 

I did it on three ATV generation II machines so far.  Will be doing the fourth install of the nightly build via my WIN7 computer tonight.  It is relatively easy.  But you have to read up on how to use a few tools (FTP and others).

Could teach yourself via more reading, and reading and reading.

 

 

There is a small glitch in the instructions:

4) Install the latest nightly build from xbmc:
a - wget <a href="http://hadm.net/%7Ekeith/xbmc_atv2/latest_atv2.deb" target="_blank">http://hadm.net/~keith/xbmc_atv2/latest_atv2.deb</a> (then hit enter and wait until its done) b - dpkg -i xbmc_atv2/latest_atv2.deb
(then hit enter and wait until its done)

if you arrow back with the cursor and remove the xbmc_atv2/ part it will run fine… it’s in the same folder !

b - $ dpkg -i  latest_atv2.deb

$ ls   will list all the files so you can see it is there

thanks Quinn and everyone else who have thrown out suggestions.  I think I have solved the problem by modifying the XBMC Video settings:  I was defaulting to one of the Audio Sync methods, but by turning off Audio Sync (and unchecking on Hardware Acceleration) I think I’ve got it workable.  I did confirm that these were the settings I have on my ATV1.  Interesting that, apparently, the defaults are different (atv1 vs atv2)… or i made the changes on the atv1 a while ago and just forgot that i had.

lankysam, this is a curious setting and apparently varies widely. I use hardware acceleration and sync to video - drop dupe audio setting on both aTV & aTV2. As long as it works all is good.

I had problems with MKV stuttering sound and picture. Disappeared when i turned off Audio Sync. Hardware Acceleration enabled seems to work fine for me (ATV2 on 4.2.2).
A big thank you for the hints 8)