xbmc logo not visible

I have an interesting problem here that others may be able to assist if possible. 


I had issues with the ‘maitenance’ atv flash app being able to install the “click to untether” feature onto my ATV2 (5.3 6105), so I went ahead and fired up Seas0nPass, updated it, and re-jailbroke my ATV2. 

I reloaded ATV flash 2.4 onto the ATV2 and the ‘maitenance’ app showed up again, no problem. 

I go to click on to install xbmc, and it shows the installation was successful, but when I go back to the main menu, the xbmc logo is not visible. The maitenance app shows that it is installed but the logo is no where to be found. 

I have done the following:

-Removed and readded xbmc with ‘maitenance’.

-Installed nito, attempted to install the xbmc, no luck there either. Also attempted to remove and reinstall, still no luck.

-Attempted to install Xbmc from the ‘nito installer’ application, still no luck.

Again, the jailbreak itself is fine, but it’s the xbmc logo specifically that is not wanting to appear on the main menu so I can access it. 


Am I missing something? Was there a step I missed upon reinstalling Seas0nPass 2.4 onto the ATV2 again? Any help would be appreciated. Thanks!

Personaly I do not use ATV Flash but sounds like it messed up. I would restore in Itunes and jailbreak again. Then run Nito Installer to install XBMC then install ATV Flash.

Thanks for your reply!


Yeah, I did a complete re-jailbreak, installed NitoTV first, tried installing XBMC through NitoTV, no luck. I’m not sure what it is. 

Hmm, not an ATV flash user either, but have you tried just to install XBMC natively through root/alpine by using a ssh terminal program and see if you see the XBMC logo then?

If you don’t get XMBC then… well then there’s something interesting with your device, but I’m almost cerrtain it’s a bug with flash.

I use nito installer to install XBMC hear is a link http://yourtechfeed.blogspot.ca/2013/04/how-to-get-xbmc-and-nito-tv-on-your.html

Okay, Update. 


I installed a fresh new jailbreak (5.3) onto the AppleTV2.


I then installed a new NitoTV, attempted to install XBMC via NitoTV and ran into this error, XBMC did not install.


"The following packages have unmet dependencies:


org.xbmc.xbmc-atv2.Depends: org.xbmc.xbmc-seatbeltunlock but no installable"


E: Broken Packages"


Any ideas folks? Thanks again for your replies. 

Try another fresh install and try the link to use nito installer i posted above this is how i have always installed XBMC.


it is very biazarre. However, if you have Plex installed; delete it. It has been known to conflict with v.12 of XBMC.




Attempted to install Xbmc via the nito installer. Nito installer shows the green check mark that it installed correctly. Apple TV still shows no Xbmc logo on the main menu.


Next step was going straight via command line, and I’m running into a POSIX: Operation timed out. Any ideas?


Thanks again. 

Weird you did restore in Itunes and re jailbreak before running nito installer? i have never had a problem and i do 15 ATV2 for myself and friends.

Correct. In fact, this happened to both of my AppleTV 2’s today. 

Correct. In fact, this happened to both of my AppleTV 2’s today.