XBMC/KODI not working E: dpkg was interrupted, you must manually run 'dpkg

Ok, so I recently installed KODI onto my jailbroken Apple TV 2. I jailbroke the Apple TV 2 a few years ago with much difficulty and care not to re-jailbreak if possible.

Anyway no that I have installed KODI on my ATV2 none of the addon’s work, I used the config wizard. I also have XBMC Frodo installed as well and it will not work either, ATV2 just reboots every time.

I installed both using NITO TV, it currently states that KODI is not installed and that XBMC needs updated. I tried doing both but I get an end message stating " E: dpkg was interrupted, you must manually run 'dpkg…

I was able to figure out how to ssh via putty to try and delete both/either XBMC or KODI but I keep getting the same error E: dpkg was interrupted, you must manually run 'dpkg

I do NOT have ATV Flash installed, a few posts made by James states that simply running or rerunning ATV Flash will solve this problem. Will it solve the problem for me if I do not have ATV Flash installed?

I also have read a few other solutions 1. stating that you just manually run “dpkg --configure -a” .Perhaps a dumb questions but how do you do that? Do you just enter “dpkg --configure -a” in putty after loginning in and entering the password?

The other solution I have found is Delete all the files in /var/lib/dpkg/updates . How would I do that?

Sorry for the newbie questions but I appreciate all the help:)

Yes, enter “dpkg --configure -a” in putty.

You can view and delete all the files in /var/lib/dpkg/updates by using a program named WINSCP

apt-get remove org.xbmc.xbmc-atv2
apt-get autoremove
rm -Rf /private/var/mobile/Library/Preferences/XBMC
rm -Rf /private/var/stash/Applications/XBMC.frappliance

Ok, thanks! Just to clarify do I just put “dpkg --configure -a” into putty or do I need the whole string?

Also do you think the ATV Flash method would fix this problem or should I go straight to putty?

Thanks again!

Also is there commands to remove KODI as well?

dpkg --configure -a is the command
As far as removing KODI… I never went beyond Gotham so I don’t know the command exactly. Use WINSCP to log into your ATV and check the directory “/private/var/mobile/Library/Preferences/” there should be an XBMC directory and the command “rm -Rf /private/var/mobile/Library/Preferences/XBMC” will get rid of it.

I believe KODI will be “/private/var/mobile/Library/Preferences/KODI” so run the command “rm -Rf /private/var/mobile/Library/Preferences/KODI” to uninstall it. Of course, you’ll have to reinstall XBMC/KODI after all this. I would manually install XBMC/KODI to give you a better outcome, Check out http://kodi.wiki/view/HOW-TO:Install_Kodi_on_Apple_TV_2 to see the process. You can do all the commands in PUTTY.