XBMC is crashing

Hello,

I jail broke my apple tv2 using the untethered method.  I installed nito tv, and through nito tv I installed XBMC with the updatebegone function.  Everything worked fine until last night.  Now when I click on XBMC my screen goes black and the apple tv2 homepage reappears.  Consequently, I can no longer get into XBMC.

Does anyone have any suggestions on how to fix this problem?

Ive already tried the following:

  • updated nito tv

  • removed and re installed XBMC

 

Thanks:)

I have exactly the same problem. Tried to fix it by reinstalling xbmc. Tried even the xbmc nightlies. Nothing helps. I have no clue what causes this.

 

I found a fix.  Do the following:

-SSH into your apple tv2 via Putty

-log in using your user name and password (default Username: root, default Password: alpine)

-Remove your databases by entering the following code: rm -f /private/var/mobile/Library/Preferences/XBMC/userdata/Database/*db 

  This will reset your video database, but the devs are looking into a fix for the DB corruption issue.

-Next reeboot your system using the reeboot command and then exit

 

Let me know if this works for you?

PS, I got the info from the following link: http://wiki.xbmc.org/index.php?title=XBMC_for_iOS_specific_FAQ#Crashing

 

worked! thanks a lot!