xbmc install fails using nito installer help required please??

 Hi all,

 

I am on a tethered 5.3 Apple TV that did have the FC logo on it, up until i ran “nito installer” I installed NitoTV and that went fine, got the logo on the main menu, next I tried to install XBMC, now although initially you think its worked because the AppleTV reboots, I end up with no XBMC logo.

So I tried to install using Nito Installer from Iphone same thing happened, rebooted no Icon for XBMC.

 

So I read somewhere about using filezilla to go into /private/var/mobile/Library/Caches/AppleTV/MainMenu and change apple.frontrow.appliance.xbmc@720.png

 

to

 

com.apple.frontrow.appliance.xbmc@720.png  but this file is not even in there.

 

The only thing i did see for a moment was that there was something “broken” which appeared on screen when I used the “Nito Installer” from a laptop running win7.

but if NitoTV installed fine whats wrong with XBMC.

I tried to install XMBC through nitoTV but got :

The following packages have unmet dependancies org.xbmc.xmbc-atv2: Depends: org.xbmc.xbmc-seatbeltunlock but not installable  E: broken packages.

 

Desperate for some help please guys…

I have no clue as to what is going on. I managed to install XBMC onto an ipad without any problems. so does this mean my appletv is no longer jailbroken, because as soon as i installed NitoTV my firecore logo dissapeared.

really appreciate any input please…

many thanks

sadsack

 

 

 

I have not got a clue what just happened but decided to at least let others know my circumstances, I left my laptop with NitoTV running with the error message displayed, and by the time I went back and pressed the menu button on the remote a load more items came up, some of them I recognised from my install onto the ipad.

I thought for a moment that the install xmbc inside nitotv had worked but it still said “not installed”.

So as a last ditch attept i retried with my iphone and nito installer this time it seemed to take a little longer, the appletv rebooted and I was met with the xmbc logo… how crazy is that.

I truly have no idea what happened but at least its on there now.

1:a quick question for any of you guys, I did read on here somewhere that Seasonpass automatically blocks updates, so would I need to install “Updatebegone” (i believe that is what it is called)…

2:other than that what is the sole purpose of NitoTV please??

3:also my FC logo has also dissapeared, I quite liked that being there, remined me that it was JBroke.

I’d appreciate any advise as to what may have happened,

many many thanks in advance as I truly don’t have anyone else to help with these questions…

sadsack

 

I cannot really speak to what happened with your process… but I CAN confirm that that the attractive “FC” logo will always disappear with the installation of NITO TV.

 

Also… I can confirm that the Nito Installer is on the fritz.  My experience matched yours last night and no number of attempts – be it via MAC or PC – could get XBMC installed.  Curiously, NITO TV could be installed and uninstalled without a problem.

I WAS able to use the NITO installer this morning, but am now runnnig into issues again tonight.  The process either starts and never completes… or, alternately, the process completes (or, more accurately, a shortened process completes) but there is no XBMC logo or installation. 

I’ve decided to hold back on re-installing xbmc for the time being,… I really did like the idea of xmbchub wizard, but for some unknown reason there “maintenance tool” suddenly broke, and no amount of uninstall/reinstalls would help, the consensus was to simply keep refreshing “Fusion” repo. that simply does not work, I then read that the maintentance tool has been moved over to mikey1234’s repo.

Also the fact that there was no intrusive advertising made xmbchub wizard a better alternative to some of the other installs available.

I’m now wondering just how invasive an installation of Nito and xmbc is to an Atv, is the Atv software protected somehow or could an install of the afore mentioned simply brick an Atv.

If we have the ability to use filezilla or winscp to be able to ssh in, is it not possible to capture a clean image backup of all files without any xbmc, this way one could simply re-insert the software back in, incase of any problems or just to do a clean start again at a later date.

I’ve just got a 3tb nas as well, so that will have to wait for the time being.

I just jailbroke an ATV to 5.3 yesterday and I use ATV flash black to install my addons, including XBMC. All installed without any problems and my XBMC is running just fine.  As soon as I installed XBMC, I ran it then exited out of it, this causes XBMC to show up in my folders when I run WinSCP. At this point I ran WinSCP and went to the /private/var/mobile/Library/Preferences/XBMC/userdata folder and edit my sources.xml file to look like this:

<sources>
    <programs>
        <default pathversion=“1”></default>
    </programs>
    <video>
        <default pathversion=“1”></default>
    </video>
    <music>
        <default pathversion=“1”></default>
    </music>
    <pictures>
        <default pathversion=“1”></default>
    </pictures>
    <files>
        <default pathversion=“1”></default>
        <source>
            <name>fusion</name>
            <path pathversion=“1”>http://fusion.xbmchub.com/</path>
        </source>
        <source>
            <name>xfinity</name>
            <path pathversion=“1”>http://xfinity.xbmctalk.com/</path>
        </source>
    </files>
</sources>

This adds the sources for repositories of fusion and xfility to my “install from zip file” link. You’ll have to exit XBMC and restart XBMC for these to show up. I then installed the hub wizard from the fusion repository and ran it.

 

Here’s some handy things to know for the future

REMOVE XBMC COMPLETLY (done through PUTTY, login as root, passward = alpine)
apt-get remove org.xbmc.xbmc-atv2
apt-get autoremove
rm -Rf /private/var/mobile/Library/Preferences/XBMC
rm -Rf /private/var/stash/Applications/XBMC.frappliance

The first line will properly uninstall XBMC, the second will remove any packages that were installed as dependencies and are no longer needed now that you have removed XBMC, the third and forth will remove the two directories that contain any leftovers. You’ll want to do this because if you don’t remove everything some of the stuff will just incorporate themselves when you reinstall XBMC.

 

If you have another device that has a good running XBMC you can copy the files from the good one to the new one by doing this:

Run WinSCP

copy all of your XBMC data, add-ons, skins, etc, to your desktop. The folder to copy is   /private/var/mobile/Library/Preferences/XBMC/ 

Now, on your new machine, install xbmc, run it once and exit, then SCP into it, copy and paste the XBMC folder from your desktop to the appropriate place on your new ATV. The final step id to PUTTY into the new machine and run this command: chown -R mobile:mobile /private/var/mobile/Library/Preferences/XBMC/   this is to reset ownership/permissions.

 

As a final note, I noticed a few of my icons were missing in my XBMC video section. The apps still ran but I all I saw of the icons were puzzle pieces. I gather something was down today and XBMC couldn’t get the icons.

 

That’s one for the Printer Carpenter940, cheers.

Very informative.

Wish I had used xmbchub on the ipad first, but I never knew about xmbchub until after i installed xfinity & xunity-talk. what a booboo.