XBMC Eden1 and 2 canot connect to external drive

With both release, regardless of the approach (SMB< AFP, ZEROCONFIG) I can get xbmc to recognize  an external drive once I name it etc., but when I try to open it…no go. Any suggestions. Under Dharma 10 it worked. Current ATV2 black.

It is working. Probably, the hard drive was in sleep mode. Made one minor tweak  on my Apple Extreme, just in case, but was most likely the sleeping drive. Used smb.

Hi Joseph can you expand some more on this issue because i having the same problems. I also got myexternal hardrive connected to my airport  extrme

I shared this with someone else who was only using their IMac But the same goes for doing the external drive except file sharing stuff is not needed.

First, make sure you have File Sharing turned on, on your IMac in system preferences. The default folder may be your public folder. You can add or delete any other, like movies etc. In Airport Utility have Workgroup as WORKGROUP. I have guest access set to read and write (not sure if it makes a difference) and I have secured disk set to password on Airport Extreme. 
XBMC on Atv2
Go to System Setting- SMB Client- Workgroup-WORKGROUP to check it.
Then go to:
Add Video
Windows Network
Public Folder, Movies or what ever you set up in System preferences for file sharing
(I tested with the default of public folder with one short video-worked fine)
That set up my IMac. 
Of course using Firecore media player is an easier set-up.
I have found the media player to be better than XBMC for playing videos.
I use XBMC for the add ons like Hulu, PBS, Icefilms and so on.
Let me know.
I don’t think I missed anything. When I first set it up, it took a bit of head scratching and some forum checks.

Thanks i will try that when i get home