XBMC+Crystal 720P mkv frequently stutters, needs a reboot to fix.

Small Q; tried several options, including reinstalling the ATV. I've read about several issues of the bcm70015 not showing up in XBMC, this is not my problem though; It shows up, but after some ffwd/rewind, stopping/starting/switching 720P movies (big bang theory, for that matter...) there seems to be a problem (stuttering, slow response from remote). At first the movie plays smooth, but when using it another point that day (or the day after) the same movie stutters like crazy. Smart installer has run, tried several (adviced) settings for video playback, but the only way to solve it is to reboot.. the kext files are added, they broadcom hd decoding can be selected in the XBMC playback.

ATV is now running 720P instead of 1080P, but the problem is still there. Updated everything, ran the latest update for XBMC etc, but the freaking thing needs to be rebooted every single time to enjoy the 720P movies.

Any help is more than welcome.

hi! Yesterday I installed the bcm970015 ... and I have the same problem!.
you have solved?



You have to activate the hardware acceleration in XBMC

System -> Video -> Playback


Best regards

Yes, perhaps that was too obvious for me to post; like i said, it (crystal hd) shows up in XBMC, and it sometimes (most occasions it simple doesn’t) work(s)

Kext files are installed, hardware acceleration is set to crystal hd in the XBMC settings. If it’s gone bad, the Crystal hardware acceleration still is enabled in XBMC.

Need to reboot the atv every single time in order to avoid the stuttering and slow response. It’s almost a 100 percent error on mine. Annoying to say at least.


restored/Reinstalled the ATV over and over, tried different skins etc. without any form of luck.


Look, more companion.


btw, in my case files are on the internal hdd