XBMC Context Menu woes

I love XBMC on the Apple TV and it’s what I use for my movie watching, but there’s a little quirk that drives me crazy.

To pull up the context menu for library updates, library edits etc I’m supposed to press and hold (long press) the Menu button. This works only once in a while. Most of the time the result is me getting sent back a screen as if I did a short press of the Menu button.

What ends up happening is that I have to try this multiple times before I finally get it and there’s no rhyme or reason to it. Same thing happens while playing a movie where I’m supposed to press and hold the Center/Ok button to do things like turn on/off subtitles etc. Most of the time it ends up just pausing the movie and I have to keep trying over and over until it does what I want.

This seems pretty easy. Press and hold for menus, but really it doesn’t do it with any consistency. 

Anybody else have this problem or maybe know the solution?

I was having a similar problem, and fixed it by changing the battery on the remote.

I’ve tried it with two Apple remotes and the Logitech Harmony One. All do the same thing unfortunately.

One workaround was to download an XBMC app on my iPhone and use the buttons on it which works great, but I’d like to use my own remotes, and it’s become an issue for other people in the house who cannot get these menus to pop up at all.