WTF, iTunes will not sync with my ATV (4.0.2 on 3.0.1)

So last night I updated my AppleTV software to 3.0.1 and I downloaded the new ATV FireCore program and created a flash drive. I did a full install and put it in the AppleTv and it loaded just fine. I did a reboot and everything seemed ok. I ran the Nito Installer and enabled the USB for external hard drive. The problem is my iTunes will not sync over to external drive. Another problem I have is my XMBC and Boxee icons have disappeared after I ran the installer for each.

External drive was formatted last night to Mac OSX Journal
Ext HD is 1TB iOmega
FireCore 4.0.2
ATV 3.0.1

The drive worked originally when I had media on it, but I erased it and reformatted to start from scratch. Am I missing something, please help!

dp

ok so it turns out it is finally transferring but it is taking forever. 4 movies have transferred and its taking over an hour to transfer each. I starting syncing the ATV about 4 hours ago and I only have 8GB transferred. It’s going to take forever. I have over 200 movies and almost 20,000 songs.