Wrong metadata language

I am from Norway, and have therefore set the language settings for metadata to Norwegian.

Sometimes strange things happen. When I press edit metadata and find the title, I see that there is a description of the movie in Norwegian. But: When I press this and Infuse returns to the folder the film is in, the metadata text is in English.

How is this possible when I have the setting set to Norwegian? Is there anything I can do about it?

Was the metadata in English before you did the edit metadata?

I’ve had it take a few minutes to update the metadata after doing an edit metadata. Not sure why but maybe the metadata server is running slow.

If I give it 3 to 5 minutes and go back the new data is showing.

Do you have a title that didn’t work right?

Is this affecting all titles or just a few?

What do you have the metadata language set to in Infuse > Settings?

Note: The upcoming 7.5 release will include a metadata language selection option right on the Edit Metadata page, which will provide more flexibility here.

Thanks for your reply.

Right now it’s the movie “Da jeg møtte Jesus…med sprettert” from the year 2000.

But it applies to quite a few more. I can name more as they come up as I go through my collection.

I also have a mystery with a collection I created in iOS not showing up on tvOS, even after a long time.

And… the TV show “Karsten og Petra” shows Norwegian episode descriptions in iOS, but English in tvOS.

Could some of this be because I have the beta version on tvOS?

Just a few, and it’s hard to understand why it happens to some while others are fine.

I have the metadata language set to “Norsk Bokmål” (Norge).

Although I don’t know if that is the reason here, it is generally a problem that there are two official written languages ​​in Norway, called “bokmål” (the main language) and “nynorsk” (kind of old school / countryside language).

So metadata in Norwegian can be marked as just “Norwegian”, or sometimes as “Norwegian Bokmål” or sometimes even “Norwegian Nynorsk” (rare).

In Infuse there are the options “Norwegian Bokmål (Norway)” and “Norwegian Bokmål”. There is even something called “English (Norway)”, which I don’t understand what it is.

I think the best thing when it comes to Norwegian would be to merge everything called anything with “Norwegian” into one. By that I mean that Infuse, if possible, could have the collective name “Norwegian” as the only option in the settings menu, and that this setting extracted metadata from everything called something with “Norwegian” in TMDB.

Can you post a few titles you are seeing this issue with?

I’ll do that. And I can investigate a little myself too if there’s some kind of logic to it. It should be. I’ll get back on this.

Edit:
I solved the problem with the movie “Da jeg traff Jesus…” by adding a “Norwegian, Bokmål” translation in TMDB. There was a “Norwegian” translation there before.

This could indicate that if I have Infuse set to “Norwegian, Bokmål” and TMDB has only “Norwegian” translation for a certain film, then Infuse will fall back to English instead of “Norwegian”. Note “Norwegian, Bokmål” and “Norwegian” are the exact same language and there should never have been two different names in the settings. “Bokmål” means “language written in books”.

The mysterious thing is that in the clear majority of cases I get a Norwegian translation in Infuse when this is the case, but for a few films I don’t.

I will find out eventually if the method of adding “Norwegian, Bokmål” translation works in all cases. If so, I can do it. It doesn’t take that many seconds. But the mystery of how this behavior seems random will still not be solved.

1 Like

Ideally, Norwegian should just be named as “Norwegian” in both TMDB and Infuse. Instead, there are three different possibilities in TMDB: Norwegian, Norwegian Bokmål and Norwegian Nynorsk. It’s a mess witch I believe only applies to Norwegian.

Infuse should remove the setting “English (Norway)” as this doesn’t make sense. There is no such thing as Norwegian-English. I don’t know how that came about.

Infuse could possibly have both “Norwegian, Bokmål” and “Norwegian” in the settings, but preferably so that you could choose “Norwegian” as main language and “Norwegian, Bokmål” as fallback 1. Then Infuse could fetch both from TMDB. Fallback number 2, if there was an option, for 99.9% of Norwegians would be English as everyone here learn English in school.

1 Like

Thanks for following up!

That makes sense now. This is an area we’d like to improve, as there are a few cases with other regional dialects (zh-HK, pt-BR, etc…) which could be better.

This is on our radar for a 7.5.x release, so not too far out.

1 Like

Awesome! Thank you very much :slightly_smiling_face:

Probably just English with waaaay better scenery. :man_shrugging:t3:

Thank you! Welcome to Norway. Beautiful nature here, but long, cold winters where you need things like Infuse to survive :smile:

3 Likes

This is troublesome.

Take as an example the TV-series “Helmer og Sigurdson”. This can be found in the following translations in the TMDB:

  • English (en-US)
  • Norwegian (no-NO)

Even if I have the metadata settings in Infuse set to “Norwegian Bokmål (Norway)”, I get English metadata. There is no option for Norwegian (no-NO) in Infuse, although there is an option for ut in TMDB.

An even weirder example is the TV show “Blindpassasjer”. This can be found in the following translations (among others) in TMDB:

  • English (en-US)
  • Norwegian (no-NO)
  • Norwegian, Bokmål (nb-NO)

Even this one only gives me English metadata no matter what I try.

It makes me quite frustrated that metadata for the Norwegian language does not work. This must be considered a bug, not a feature request. This should have worked.

Many films and TV shows get English metadata, despite the fact that there are excellent Norwegian translations in TMDB.

Of course, I have the settings in Infuse set to “Norwegian Bokmål (Norway)” in both iOS and tvOS.

I change metadata manually to Norwegian for specific movies / TV shows again and again, but soon after they switch back to English by themselves.

Please fix this soon. This has a lot to say for the overall experience when using Infuse.

Can we choose the metadata order by ourselves?
2023-03-29 135230

For example:

  1. English (en-US)
  2. English (en-AU)
  3. English (en-CA)

When it can’t find the first, it searches for the second, and so on

Can you please add Norwegian as an option in Infuse? Now Norwegian bokmål is the only option, and most translations in TMDB is in Norwegian, not Norwegian bokmål.

As Norwegian and Norwegian bokmål is the same language, it’s meaningless to seperate them in TMDB, but since Infuse has only Norwegian bokmål as an option I get stuck.

Thank you.

We have some improvements queued up to improve the fallback if certain languages or elements are not present.

And please delete the option English (Norway) in case that causes any trouble.

I just added Norwegian and Norwegian bokmål translations to the movie «Kvitebjørn kong Valemon» (1991) («The Polar Bear King» is the English title) in TMDB as one more test, but still get English mestdata.

James, this happens when the translation is present in TMDB, so it should not be necessary to fallback at all.

Today’s 7.5.3 update has a number of improvements for regional languages and dialects.

Please let us know if you continue to see any issues here.

1 Like