Wrong language metadata for TV shows

Hi guys!
My first post here. First of all, I wanted to thank you for your amazing product, I’ve been using for quite a time and I can say that this is the best experience among similar products.

That said, I’ve been experiencing a weird issue with TV shows artwork lately. My metadata language is always set to English. All metadata and artwork for movies work fine but when it comes to TV shows, some of the seasons display artwork in Russian.
However I found this issue only when browsing TV shows through favorites (which is my main flow), it’s all fine when I browse the shows through Library.

I’ve tried some things and figured out that for some reason my Apple TV’s language (Russian) somehow ‘overrides’ language (English) in Infuse settings which affects in some TV shows or even some certain seasons of TV shows having posters in Russian.

Do you know if there’s a fix for that other than having Apple TV’s language in English?

Welcome to the forum!

First thing I’d suggest is to check on TVDB and make sure they even have an English poster for the specific series and season. I have had a few instances of TV artwork that was set for English but what was on the actual poster was in a different language. If you find either case you can request through their forum to have it corrected.

If you’re library is showing the right poster and you’re not seeing the right one in your share folders you may want to try doing an Edit Metadata on one of the episodes showing the wrong artwork and re-select the correct series and see if it gets corrected.

If you can provide a couple of examples of series and seasons that are giving you problems we can help check.

I checked TVDB, it had both russian and english posters for the shows that were in question. Actually, what surprised me is that I didn’t find a russian poster for one of them (Castle Rock, Season 2) so I have no idea where it’s taking it from.

I’ve also tried Edit Metadata option but it didn’t change anything.

Here’s my result so far. So I’ve set English as preferred language in my Apple TV’s settings and in metadata settings in Infuse.
After that I have deleted metadata cache and Infuse has updated all of the artwork with english posters. So everything looks fine.

(now before you say anything, New Girl is my wife’s favorite show and it’s actually pretty funny if you give it a try, so don’t judge me)

Now when I change language to Russian in my ATV’s settings and go back to Infuse it stays the same, no russian posters, everything is fine. But when I try to use Edit Metadata on some of them, it changes the poster to russian artwork. Here’s an example of it:

Here I’ve used Edit Metadata on What We Do in the Shadows, Mandalorian and Castle Rock and the artwork changed on all of them.

What funny is that in case of What We Do in the Shadows, it just changes the artwork but it stays english. I’ve checked with TVDB and it has both russian and english posters for that.

Just one quick question, didn’t Infuse move from TVDB to TMDB for tv shows’ artwork?

Nope, it’s still TVDB for TV and TMDB for movies. I’ll dig around some more and see what I can find with your examples. It may be a simple case of ATV settings fighting with Infuse settings but I don’t know for sure.

About how may shows are you seeing issues with? Just trying to get a idea of scale. 10 out of 100, 10 out of 1000, 10 out of 20…

Hard to tell really how many shows it affects because I rotate them quite often. But if we take my screenshot as an example, out of 11 shows (2 shows use custom poster) 7 of them changed their artwork.

Okay, maybe a silly question but what do you have set for language in the Infuse metadata choice?

English, English (United States), English (UK) etc or Auto?

Just English

Just as a test, could you try the “English (United States)” ? It probably won’t make a difference but maybe TVDB is responding to different “English” info requests differently.

I think that’s the one that’s selected because I don’t have a separate “English (United States)” option.
However I do have “English (Ukraine)” which is my country but I have no idea what it means.

Heck, give it a try. :wink:

Ok, that’s some weird option that changes based on ATV’s settings.
If ATV’s language is set to English, the option says “English (Ukraine)”.
If ATV’s language is set to Russian, the option says “Russian (Ukraine)”.

So yeah, I don’t know what it does because after trying it it looks like it doesn’t really change anything.

This is still a problem for me as well. The Mandalorian simply refuses to pull Metadata.

So you’re getting all Russian for Mandalorian instead of English?