Wrong DHCP?

My ATV gen 2 is not showing the correct IP address for the DHCP i have running on my Airport Extreme. It isn’t hampering my ability to access netflix or what-have-you, but I can no longer see local computers as evidenced by my lack of Plex servers. Very strange problem. I did force a manual IP and used the dhcp on my router to distribute the IP but then the internet wouldn’t function. Any ideas?

Looks like I put this in the wrong forum, would the mods kindly move this to ATV2 troubleshooting?

Same thing is happening on my AppleTV2; it was working for about a week, then it stopped recognizing the network… Tried unplugging and plugging power as well as network cable or wifi. None seems to work - anyone with any ideas? Router is a Linksys E3200, all other network device works.


[EDIT:  sorry, I know this section is for ATV1… But I thought I’d tag along when this gets moved.  The good news is that I’ve re-jailbroken my ATV2 and updated it to aTV Flash black 1.1 and it worked again… There is now an issue with connecting to the NAS though: http://forum.firecore.com/topic/6020?page=1#comment-26700]