Won't get to DFU MODE, here is what worked for me

I was reading every post I could then I found the one below and it worked for me. Here is some other info that may help. The light will start flashing slow when the USB is connected. As you hold the menu and play/pause buttons the flashing will increase. I held those two together waiting for notification that it was in DFU mode but it never came until I let go of the buttons. Hold them for 7 seconds then release and it will take a few more seconds for the box to let you know that the ATV has been recognized


  1. Connect ATV2 up to a power source (contrary to the instructions)).

  2. Open iTunes

  3. Hook up the micro USB.

  4. Then remove the power cable (standby light should be blinking), wait a second or two and then press ‘menu’ and ‘pause’ together for 7 seconds.

I will second this as the only advice that worked for me too after banging my head against a wall for MANY MANY hours trying to get the thing to gop into DFU mode.  Also good advice for people just embarking on this often frustrating but extremely fruitful process (the amount of content available on XBMC through the Icefilms plugin alone will convince you to never pay Comcast or any other provider a dime forever more…) is to be sure that you are using a GOOD MICRO USB CABLE.  A lot of problems getting into DFU mode seem to be the result of cables that don’t play nice with the appleTV box.  This includes converters.  I bought converter off of Ebay for 99 cents, and it never worked.  I then ordered a “blackberry micro USB cable” Once I got that cable, I still had issues until I followed the instructions in the post above.  After I did that, I could get the device to go into DFU mode without steps 1 and 2.  Also sometimes I would press ‘menu’ and ‘pause’ for seven seconds… if nothing happened, then ‘menu’ and ‘down’ button for 7 seconds, then back to ‘menu’ and ‘pause’ for 7.